Bug 140245 - Buffer I/O error on removable SCSI JAZ drive
Buffer I/O error on removable SCSI JAZ drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 13:54 EST by Marek Kassur
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-17 18:51:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Kassur 2004-11-21 13:54:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
I use Iomega JAZ drive for daily backups. I see these erros in system
logs (media is unmounted):

Nov 21 18:44:14 bpmok kernel: sdc: Spinning up
disk....................ready
Nov 21 18:44:14 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 18:44:14 bpmok kernel: sdc: Write Protect is off
Nov 21 18:44:14 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 18:44:14 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 18:44:14 bpmok kernel: sdc: Write Protect is off
Nov 21 18:44:14 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 18:44:14 bpmok kernel:  sdc:<3>Buffer I/O error on device sdc,
logical block 0
Nov 21 18:44:14 bpmok kernel: Buffer I/O error on device sdc, logical
block 1
Nov 21 18:44:14 bpmok kernel: Buffer I/O error on device sdc, logical
block 2
Nov 21 18:44:14 bpmok kernel: Buffer I/O error on device sdc, logical
block 3
Nov 21 18:44:14 bpmok kernel: Buffer I/O error on device sdc, logical
block 0
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 1
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 2
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 3
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 1045524
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 1045524
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 0
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 1
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 2
Nov 21 18:44:15 bpmok kernel: Buffer I/O error on device sdc, logical
block 3
Nov 21 18:44:15 bpmok kernel:  unable to read partition table
Nov 21 18:44:15 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 18:44:15 bpmok kernel: sdc: Write Protect is off
Nov 21 18:44:15 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 18:44:15 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 18:44:15 bpmok kernel: sdc: Write Protect is off
Nov 21 18:44:15 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 18:44:15 bpmok kernel:  sdc: sdc1
Nov 21 19:14:33 bpmok kernel: sdc: Spinning up
disk....................ready
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 19:14:33 bpmok kernel: sdc: Write Protect is off
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 19:14:33 bpmok kernel: sdc: Write Protect is off
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 19:14:33 bpmok kernel:  sdc:<3>Buffer I/O error on device sdc,
logical block 0
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 1
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 2
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 3
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 0
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 1
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 2
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 3
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 1045524
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 1045524
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 0
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 1
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 2
Nov 21 19:14:33 bpmok kernel: Buffer I/O error on device sdc, logical
block 3
Nov 21 19:14:33 bpmok kernel:  unable to read partition table
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 19:14:33 bpmok kernel: sdc: Write Protect is off
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: 2091050 512-byte hdwr
sectors (1071 MB)
Nov 21 19:14:33 bpmok kernel: sdc: Write Protect is off
Nov 21 19:14:33 bpmok kernel: SCSI device sdc: drive cache: write back
Nov 21 19:14:33 bpmok kernel:  sdc: sdc1

However drive seems to wrok normally.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. connect JAZ drive
2. many I/O errors in /var/log/messages
3.
    

Additional info:

lspci -v -s 02:02.0
02:02.0 SCSI storage controller: Adaptec AHA-7850 (rev 03)
        Subsystem: Adaptec AHA-2904/Integrated AIC-7850
        Flags: bus master, medium devsel, latency 32, IRQ 201
        I/O ports at b400 [disabled] [size=256]
        Memory at feafd000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 1

kernel: ahc_pci:2:2:0: Host Adapter Bios disabled.  Using default SCSI
device parameters
kernel: scsi1 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
kernel:         <Adaptec 2902/04/10/15/20C/30C SCSI adapter>
kernel:         aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs
kernel:
kernel: (scsi1:A:0): 10.000MB/s transfers (10.000MHz, offset 15)
kernel:   Vendor: iomega    Model: jaz 1GB           Rev: H.71
kernel:   Type:   Direct-Access                      ANSI SCSI
revision: 02
kernel: SCSI device sdc: 2091050 512-byte hdwr sectors (1071 MB)
kernel: sdc: Write Protect is off
kernel: SCSI device sdc: drive cache: write back
kernel:  sdc: sdc1
kernel: Attached scsi removable disk sdc at scsi1, channel 0, id 0, lun 0
Comment 1 Marek Kassur 2004-11-21 20:18:22 EST
After some test I see that haldaemon spin up JAZ drive.
Comment 2 Marek Kassur 2004-11-24 19:35:25 EST
I have two USB pen drives, one is 32MB USB 1.1, second is 512MB USB
2.0. I see almost identical error with second one, maybe it's
something in SCSI layer ?

usb 5-2: new full speed USB device using address 3
scsi3 : SCSI emulation for USB Mass Storage devices
  Vendor:           Model:                   Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sdb: 64000 512-byte hdwr sectors (33 MB)
sdb: Write Protect is off
sdb: Mode Sense: 0b 00 00 08
sdb: assuming drive cache: write through
 sdb: sdb1
Attached scsi removable disk sdb at scsi3, channel 0, id 0, lun 0
USB Mass Storage device found at 3


usb 1-7: new high speed USB device using address 7
scsi5 : SCSI emulation for USB Mass Storage devices
  Vendor:           Model: USB DRIVE         Rev: 2.00
  Type:   Direct-Access                      ANSI SCSI revision: 02
sdc: Unit Not Ready, sense:
Current : sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sdc : READ CAPACITY failed.
sdc : status=1, message=00, host=0, driver=08
Current sd: sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sdc: test WP failed, assume Write Enabled
sdc: assuming drive cache: write through
sdc: Unit Not Ready, sense:
Current : sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sdc : READ CAPACITY failed.
sdc : status=1, message=00, host=0, driver=08
Current sd: sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sdc: test WP failed, assume Write Enabled
sdc: assuming drive cache: write through
sdc: Unit Not Ready, sense:
Current : sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sdc : READ CAPACITY failed.
sdc : status=1, message=00, host=0, driver=08
Current sd: sense key Unit Attention
Additional sense: Not ready to ready change, medium may have changed
sdc: test WP failed, assume Write Enabled
sdc: assuming drive cache: write through
 sdc:end_request: I/O error, dev sdc, sector 0
Buffer I/O error on device sdc, logical block 0
Buffer I/O error on device sdc, logical block 0
Buffer I/O error on device sdc, logical block 262143
Buffer I/O error on device sdc, logical block 262143
Buffer I/O error on device sdc, logical block 0
 unable to read partition table
 sdc:<3>Buffer I/O error on device sdc, logical block 0
Buffer I/O error on device sdc, logical block 262143
Buffer I/O error on device sdc, logical block 0
 unable to read partition table
Attached scsi removable disk sdc at scsi5, channel 0, id 0, lun 0
USB Mass Storage device found at 7
hub 1-0:1.0: connect-debounce failed, port 8 disabled
Comment 3 Dave Jones 2005-07-15 16:17:29 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Marek Kassur 2005-07-17 18:51:40 EDT
This bug is already fixed in previous kernels, I think 2.6.11.
BTW, kernel-2.6.12-1.1372_FC3 failed to boot on this machine (kernel panic), but
this is another story.

Note You need to log in before you can comment on or make changes to this bug.