Bug 140256 - /usr/bin/system-config-securitylevel command gives error results (detailed below)
/usr/bin/system-config-securitylevel command gives error results (detailed be...
Status: CLOSED DUPLICATE of bug 139155
Product: Fedora
Classification: Fedora
Component: system-config-securitylevel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 15:23 EST by Terry Linhardt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Linhardt 2004-11-21 15:23:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The installed icon "Security level" does not function. From the
command line, I ran the command:

/usr/bin/system-config-securitylevel. I got the following output:

]# /usr/bin/system-config-securitylevel
Traceback (most recent call last):
  File
"/usr/share/system-config-securitylevel/system-config-securitylevel.py",
line 18, in ?
    app.stand_alone()
  File "/usr/share/system-config-securitylevel/securitylevel.py", line
427, in s tand_alone
    self.selinuxPage = selinuxPage.selinuxPage()
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line
329, in __i nit__
    self.refreshTunables(self.initialtype)
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line
427, in ref reshTunables
    self.loadBooleans()
  File "/usr/share/system-config-securitylevel/selinuxPage.py", line
418, in loa dBooleans
    on=rec[3]=="1"
IndexError: list index out of range


Version-Release number of selected component (if applicable):
system-config-securitylevel-1.4.14-1

How reproducible:
Always

Steps to Reproduce:
1.Run the command /usr/bin/system-config-security level from the
command line
2.
3.
    

Actual Results:  See above (description)

Expected Results:  Ability to change security levels.

Additional info:

Tried this on two different machines. Both with all updates applies as
of 11/21/2004.
Comment 1 Sitsofe Wheeler 2004-11-22 05:27:18 EST
This looks like a dup of bug 139155
Comment 2 Terry Linhardt 2004-11-22 09:44:46 EST
I agree. Sorry, I did a query but missed it.
Comment 3 Paul Nasrat 2004-11-22 10:06:09 EST

*** This bug has been marked as a duplicate of 139155 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:07:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.