Bug 140263 - FC3 unzip fails for certain files
Summary: FC3 unzip fails for certain files
Status: CLOSED DUPLICATE of bug 134073
Alias: None
Product: Fedora
Classification: Fedora
Component: unzip   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-21 21:13 UTC by eparsons
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bin-latex.i386-linux.zip (396 bytes, application/octet-stream)
2004-11-21 21:14 UTC, eparsons
no flags Details

Description eparsons 2004-11-21 21:13:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Unzip bundled with FC3 seems to break on certain zip files.  The
problem was noted while installing TeX Live, but probably can be
reproduced elsewhere.

Donwloading original unzip sources and compiling makes the problem go
away.

One of the files in the TeX Live distribution that demonstrates the
problem is "bin-latex.i386-linux.zip".  When running /usr/bin/unzip
(rpm unzip-5.51-4), one gets the following output:
$ unzip bin-latex.i386-linux.zip
Archive:  bin-latex.i386-linux.zip
    linking: bin/i386-linux/latex    warning:  symbolic link
(bin/i386-linux/latex) failed
error:  zipfile probably corrupt (segmentation violation)

When running a natively compiled version of unzip, one gets the
correct behavior:
$ unzip-5.51/unzip bin-latex.i386-linux.zip
Archive:  bin-latex.i386-linux.zip
    linking: bin/i386-linux/latex    -> pdfetex
  inflating: texmf/lists/bin-latex.i386-linux
finishing deferred symbolic links:
  bin/i386-linux/latex   -> pdfetex




Version-Release number of selected component (if applicable):
unzip-5.51-4

How reproducible:
Always

Steps to Reproduce:
1. run unzip on the specified file
2.
3.
    

Actual Results:  $ unzip bin-latex.i386-linux.zip
Archive:  bin-latex.i386-linux.zip
    linking: bin/i386-linux/latex    warning:  symbolic link
(bin/i386-linux/latex) failed
error:  zipfile probably corrupt (segmentation violation)

Expected Results:  $ unzip-5.51/unzip bin-latex.i386-linux.zip
Archive:  bin-latex.i386-linux.zip
    linking: bin/i386-linux/latex    -> pdfetex
  inflating: texmf/lists/bin-latex.i386-linux
finishing deferred symbolic links:
  bin/i386-linux/latex   -> pdfetex

Additional info:

Comment 1 eparsons 2004-11-21 21:15:00 UTC
Created attachment 107144 [details]
bin-latex.i386-linux.zip

The attached file can be used to reproduce the problem

Comment 2 Lon Hohberger 2004-11-22 19:37:59 UTC
Excellent testcase.

*** This bug has been marked as a duplicate of 134073 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:07:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.