Bug 140300 - Omni doesn't look in 64-bit lib directories
Summary: Omni doesn't look in 64-bit lib directories
Status: CLOSED DUPLICATE of bug 141421
Alias: None
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
(Show other bugs)
Version: 3
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-22 06:54 UTC by Paul Wayper
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 10:06:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Wayper 2004-11-22 06:54:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
Installing a new LaserJet printer on an Opteron system will allow you
to install a printer but will never print.  By setting LogLevel debug
in the /etc/cups/cupsd.conf file, it can be seen that it's looking for
the Omni device drivers in /usr/lib/Omni.  On 64-bit systems these
drivers are loaded in /usr/lib64/Omni and are not present in the
former directory.  Therefore the printer driver does not load and
printing never works.

Version-Release number of selected component (if applicable):
cups-1.1.22-1

How reproducible:
Always

Steps to Reproduce:
1. Change the LogLevel in /etc/cups/cupsd.conf to debug
2. Create a new printer using e.g. a HP LaserJet driver.
3. Print a test page


Actual Results:  Nothing is printed.

The /var/log/cups/error_log has similar to the following lines:
D [22/Nov/2004:17:56:47 +1100] [Job 21] Omni::openLibrary: for
"libHP_LaserJet_4000T_TN.so", g_module_error returns
"libHP_LaserJet_4000T_TN.so: cannot open shared object file: No such
file or directory"
D [22/Nov/2004:17:56:47 +1100] [Job 21]
D [22/Nov/2004:17:56:47 +1100] [Job 21] Omni::openLibrary: Omni device
library not found in the following paths:
D [22/Nov/2004:17:56:47 +1100] [Job 21] /usr/lib/Omni/.
D [22/Nov/2004:17:56:47 +1100] [Job 21] .


Expected Results:  The test page was printed.

Additional info:

I included /etc/lib64/Omni in the /etc/ld.so.conf but this did not fix
the problem.

Comment 1 Tim Waugh 2004-11-22 11:15:07 UTC
I need to know what version of Omni you have.  You've put 'fc3' in the version
field but cups-1.1.22-1 is a rawhide package, so perhaps you have Omni 0.9.2?

Comment 2 Tim Waugh 2004-12-03 10:06:55 UTC
No feedback, but looks like a duplicate of bug #141421.

*** This bug has been marked as a duplicate of 141421 ***


Note You need to log in before you can comment on or make changes to this bug.