Bug 14031 - wrong vfs used
Summary: wrong vfs used
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-15 13:33 UTC by borgia
Modified: 2013-04-02 04:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-18 11:54:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description borgia 2000-07-15 13:33:53 UTC
Tapping enter on sendmail-cf and sendmail-doc rpms (disc2) invokes elm, not rpmfs.

Comment 1 David Mason 2000-07-17 14:46:37 UTC
Preston - not sure why this was assigned to us - please send to appropriate
person

Comment 2 borgia 2000-07-28 18:59:32 UTC
The culprit is /usr/lib/mc/mc.ext: elm is started by the type/mail handler, that unfortunately matches a partial response of 'file' to the 'mail'
string, thus invoking elm instead of rpm on every package whose name contains the mail substring (happens with xmailbox, too).
I  am raising the priority since it is still not fixed.

Comment 3 Andrea Borgia 2000-08-09 12:42:37 UTC
Still present in beta 5 (Pinstripe)

Comment 4 Preston Brown 2000-08-15 15:02:04 UTC
can you guys hack up MC to fix this please dave?

Comment 5 Nalin Dahyabhai 2000-08-17 22:15:41 UTC
The latest file and gmc package don't exhibit this behavior -- gmc tries to open
gnorpm if I hit Enter while the sendmail-cf package from the build tree is
selected.

Comment 6 borgia 2000-08-18 11:54:13 UTC
Could you please check also mc (not gmc)? I have never used gmc.

Comment 7 Jonathan Blandford 2000-08-21 18:34:17 UTC
Okay.  This should be fixed in rawhide now.  I removed the 'elm' command as it
was of debatable worth, anyway.


Note You need to log in before you can comment on or make changes to this bug.