Bug 140317 - (IT_35337) Possible crash on nautilus startup
Possible crash on nautilus startup
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 146197 (view as bug list)
Depends On:
Blocks: 136201 132991
  Show dependency treegraph
 
Reported: 2004-11-22 05:26 EST by Bastien Nocera
Modified: 2013-03-13 00:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 09:45:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2004-11-22 05:26:57 EST
Every now and then, nautilus would crash on startup:
#3  <signal handler called>
No symbol table info available.
#4  0xf56c2870 in FAMClose () from /usr/lib/libfam.so.0
No symbol table info available.
#5  0xf56c29f5 in FAMMonitorDirectory () from /usr/lib/libfam.so.0
No symbol table info available.
#6  0xf570e7d7 in ?? () from /usr/lib/gnome-vfs-2.0/modules/libfile.so
No symbol table info available.

This is the same as GNOME upstream bug 111147
http://bugzilla.gnome.org/show_bug.cgi?id=111147

Those 3 patches should help (need to be applied in that order):
http://cvs.gnome.org/viewcvs/gnome-vfs/modules/file-method.c?r1=1.119&r2=1.120&makepatch=1&diff_format=u
http://cvs.gnome.org/viewcvs/gnome-vfs/modules/file-method.c?r1=1.120&r2=1.121&makepatch=1&diff_format=u
http://cvs.gnome.org/viewcvs/gnome-vfs/modules/file-method.c?r1=1.121&r2=1.122&makepatch=1&diff_format=u
Comment 1 Bastien Nocera 2005-01-26 05:50:13 EST
*** Bug 146197 has been marked as a duplicate of this bug. ***
Comment 2 John (J5) Palmieri 2005-02-09 19:26:32 EST
Patched and building as errata
Comment 3 John (J5) Palmieri 2005-02-09 20:26:08 EST
Errata submitted
Comment 4 Tim Powers 2005-05-19 09:45:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-148.html

Note You need to log in before you can comment on or make changes to this bug.