Bug 140332 - Oops in ide_wait_not_busy with APM
Summary: Oops in ide_wait_not_busy with APM
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-22 13:11 UTC by Didier
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-14 19:21:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Didier 2004-11-22 13:11:40 UTC
Description of problem:
Start kernel in APM mode ; suspend ; resume.
-> oops.


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3


How reproducible:
Always after the first suspend/resume cycle after a restart ;
appearantly not occuring after subsequent suspend/resumes without
restarting.
 

Steps to Reproduce:
1. boot in single mode with kernel parameter "acpi=off"
2. # apm -s
3. resume after successful suspend.
  
Actual results:
Oops :

Nov 22 13:47:18 dmbr042 kernel: Badness in ide_wait_not_busy at
drivers/ide/ide-iops.c:1342
Nov 22 13:47:18 dmbr042 kernel:  [<02269a90>] ide_wait_not_busy+0x4b/0x7b
Nov 22 13:47:18 dmbr042 kernel:  [<02267478>] start_request+0xc0/0x1c1
Nov 22 13:47:18 dmbr042 kernel:  [<02267870>] ide_do_request+0x2dd/0x39e
Nov 22 13:47:18 dmbr042 kernel:  [<02268225>] ide_intr+0x3c2/0x450
Nov 22 13:47:18 dmbr042 kernel:  [<0226dabf>] ide_dma_intr+0x0/0x7a
Nov 22 13:47:18 dmbr042 kernel:  [<02107f51>] handle_IRQ_event+0x25/0x4f
Nov 22 13:47:18 dmbr042 kernel:  [<021089e0>] do_IRQ+0x151/0x290
Nov 22 13:47:18 dmbr042 kernel:  [<0211007b>] mtrr_open+0x7/0x2b
Nov 22 13:47:18 dmbr042 kernel:  [<0211644d>]
apm_bios_call_simple+0x65/0x95
Nov 22 13:47:18 dmbr042 kernel:  [<0211654f>] apm_do_idle+0x12/0x5c
Nov 22 13:47:18 dmbr042 kernel:  [<02116668>] apm_cpu_idle+0xb0/0x128
Nov 22 13:47:18 dmbr042 kernel:  [<0210408c>] cpu_idle+0x1f/0x34
Nov 22 13:47:18 dmbr042 kernel:  [<023ad6bb>] start_kernel+0x216/0x219


Additional info :
IBM ThinkPad A30p, model #2653, with a second 2.5" harddisk in the
Ultrabay slot (/dev/hdb).

Comment 1 Dave Jones 2005-07-15 19:30:05 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Didier 2005-08-14 19:21:39 UTC
As I have changed machines, I am unable to verify any fixes for the APM
behaviour on the IBM ThinkPad A30p.




Note You need to log in before you can comment on or make changes to this bug.