Bug 140348 - up2date crashes or hangs on certain packages
up2date crashes or hangs on certain packages
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 141629 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 10:22 EST by Taco Scargo
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 06:10:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taco Scargo 2004-11-22 10:22:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Using RHEL4 WS beta 2 and trying to up2date the system, the up2date
tool   �hangs' in X11 environments (without any warnings) on the
Downloading headers to solve dependencies box. Using up2date in a
terminal (up2date -u) gives the following output:

Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1119, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 74, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 159, in
__dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 553, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 520, in
process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 307, in
__dependencies
    msgCallback = self.msgCallback)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 93, in solveDep
    msgCallback = msgCallback)
  File
"/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
44,  in solveDep
    msgCallback = self.msgCallback)
TypeError: getSolutions() got an unexpected keyword argument
'progressCallback'


Version-Release number of selected component (if applicable):
up2date-4.3.53-1

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL4 WS beta 2
2. register with RHN
3. up2date -u
    

Actual Results:  see error in description

Expected Results:  up2date should not crash

Additional info:

This bug was also reported in FC3 under 138641

Possibly it is related to bug 140160
Comment 1 Thomas Amsler 2004-11-22 12:16:43 EST
I run into the same problem and it crashes up2date on any of the
following packages while updating WS4 Beat2

Fetching Obsoletes list for channel: rhel-i386-ws-4-beta...

Name                                    Version        Rel
----------------------------------------------------------
chkconfig                               1.3.11.2       1             
   i386
curl                                    7.12.1         3             
   i386
curl-devel                              7.12.1         3             
   i386
httpd                                   2.0.52         7.ent         
   i386
httpd-manual                            2.0.52         7.ent         
   i386
httpd-suexec                            2.0.52         7.ent         
   i386
mod_ssl                                 2.0.52         7.ent         
   i386
ntsysv                                  1.3.11.2       1             
   i386

Comment 2 Adrian Likins 2004-11-22 12:53:11 EST
fixed in later versions (4.3.65 for example)
Comment 3 Taco Scargo 2004-11-22 13:50:16 EST
4.3.53 is the latest version available for RHEL 4 WS Beta (2) on RHN.
Can someone push the new version onto RHN ?
Comment 4 Joshua Wilson 2004-12-02 12:41:09 EST
*** Bug 141629 has been marked as a duplicate of this bug. ***
Comment 5 Jay Turner 2005-01-14 06:10:13 EST
Closing out.

Note You need to log in before you can comment on or make changes to this bug.