Bug 1403662 - Ceph update not installable
Summary: Ceph update not installable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ceph
Version: 25
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Boris Ranto
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-12 06:41 UTC by Mattias Ellert
Modified: 2017-03-13 23:49 UTC (History)
9 users (show)

Fixed In Version: ceph-10.2.4-2.fc25 ceph-10.2.4-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-13 23:49:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Mattias Ellert 2016-12-12 06:41:22 UTC
Description of problem:

# dnf --refresh update --best
Error: package libcephfs1-devel-1:10.2.2-3.fc25.x86_64 requires libcephfs1 = 1:10.2.2-3.fc25, but none of the providers can be installed.
package libcephfs_jni1-devel-1:10.2.2-3.fc25.x86_64 requires libcephfs_jni1 = 1:10.2.2-3.fc25, but none of the providers can be installed.
package librados2-devel-1:10.2.2-3.fc25.x86_64 requires librados2 = 1:10.2.2-3.fc25, but none of the providers can be installed.
package libradosstriper1-devel-1:10.2.2-3.fc25.x86_64 requires libradosstriper1 = 1:10.2.2-3.fc25, but none of the providers can be installed.
package librbd1-devel-1:10.2.2-3.fc25.x86_64 requires librbd1 = 1:10.2.2-3.fc25, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

Version-Release number of selected component (if applicable):

ceph-10.2.4-1.fc25

How reproducible:

Aöways

Steps to Reproduce:
1. dnf update (with the previous version installed)

Actual results:

Failed update (see above)

Expected results:

Successful update

Additional info:

The reason for the problem is that the new version renames some packages without obsoleting the old versions. There are obsoletes in the packages but they are obsoleting an exact version of the old names - a version that never existed, instead of all versions less than the version where the name was changed.

$ grep Obsoletes ceph.spec | grep =
Obsoletes:	librados2-devel = %{epoch}:%{version}-%{release}
Obsoletes:	librgw2-devel = %{epoch}:%{version}-%{release}
Obsoletes:	libradosstriper1-devel = %{epoch}:%{version}-%{release}
Obsoletes:	librbd1-devel = %{epoch}:%{version}-%{release}
Obsoletes:	libcephfs1-devel = %{epoch}:%{version}-%{release}
Obsoletes:	libcephfs_jni1-devel = %{epoch}:%{version}-%{release}

Comment 1 Christophe Fergeau 2016-12-29 10:00:51 UTC
Are there plans for a fixed f25 build?

Comment 2 Daniel 2017-01-11 09:45:11 UTC
When will this bug be fixed?
I have waited for a month. There are still 19 packages I cannot update.

Comment 3 Brad Hubbard 2017-01-11 21:20:46 UTC
Would erasing the devel packages, upgrading, and then putting the devel packages back (if you need them, they are generally not required) work?

Comment 4 Mattias Ellert 2017-01-12 06:43:13 UTC
The upgrade path is broken. It needs to be fixed.

Comment 5 Boris Ranto 2017-01-12 16:03:16 UTC
I have fixed this a long time ago but I've been running into technical issues for the last month when trying to push the update. First, I ran into issues with new fedkpg certification method which was eventually fixed in January (maybe a bit earlier, I did not check during the christmas period).

However, now, there are some issues with libxfs in 32-bit builds in rawhide[1]  (the same package builds fine in f24, f25) and unfortunately, I can't push the update when what we have in rawhide is older than what is being pushed to f24/f25.

[1] https://kojipkgs.fedoraproject.org//work/tasks/7909/17257909/build.log

Comment 6 Fedora Update System 2017-01-13 00:47:24 UTC
ceph-10.2.4-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-598e3c5542

Comment 7 Fedora Update System 2017-01-13 00:47:36 UTC
ceph-10.2.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-75eab2ad5a

Comment 8 Boris Ranto 2017-01-13 00:53:07 UTC
I've managed to hack around the xfs issue in rawhide so I have pushed the f24/f25 packages to bodhi.

Comment 9 Fedora Update System 2017-01-13 08:33:07 UTC
ceph-10.2.4-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-598e3c5542

Comment 10 Fedora Update System 2017-01-14 03:52:42 UTC
ceph-10.2.4-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-03-04 00:50:03 UTC
ceph-10.2.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-75eab2ad5a

Comment 12 Fedora Update System 2017-03-13 23:49:46 UTC
ceph-10.2.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.