Bug 140369 - Wrong kernel installed a 2 CPU Xeon EM64T system
Wrong kernel installed a 2 CPU Xeon EM64T system
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia32e Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 12:01 EST by Daniel Riek
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 23:51:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2004-11-22 12:01:40 EST
Description of problem:
Partner reports that on a 2 CPU Xeon EM64T system besides the correct
SMP kernel for hyperthreading Xeons kernel-2.4.21-20.EL.ia32e also the
AMD64 SMP kernel kernel-smp-2.4.21-20.EL.x86_64 gets installed.

Version-Release number of selected component (if applicable):
anaconda-9.1.3-3

How reproducible:
Install RHEL3U3 ES x86_64 on a 2 CPU Xeon EM64T machine
Comment 1 Jeremy Katz 2004-11-22 12:03:25 EST
Are they doing a kickstart install?  If so, do they have kernel-smp
listed in their %packages section?
Comment 2 Udo Seidel 2004-11-23 14:19:21 EST
It was a kickstart install and the kernel-smp is listed in the
%packages section. Removing this entry it works like a charm. 

Why is the AMD64 SMP kernel made as default when it gets installed?
Comment 3 Jeremy Katz 2004-11-24 23:51:16 EST
This was one of the problem scenarios outlined when we decided to go
this route for supporting EM64T in RHEL3.

Unfortunately, we could *not* change the architecture of the kernel
for AMD64 without breaking up2date within RHEL3.  This meant that the
kernel for AMD64 boxes had to remain as "x86_64".  This kernel is
unfortunately not compatible with EM64T boxes, though.  But due to the
fact that every other package in the distribution is "x86_64", we had
to have the arch as compatible in the RPM sense with the "ia32e" arch.
 But it was deemed that the inconvenience and confusions that could
result were less of a problem than the possibility of regression by
integrating the changes to support EM64T in the base "x86_64" kernel.

Note You need to log in before you can comment on or make changes to this bug.