Bug 140427 - Cannot copy files to SMB mounted directory after upgrading to kernel 2.6.9-1.681_FC3
Cannot copy files to SMB mounted directory after upgrading to kernel 2.6.9-1....
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 141365 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 16:17 EST by Radu Cornea
Modified: 2015-01-04 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:55:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radu Cornea 2004-11-22 16:17:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
After installing kernel-2.6.9-1.681_FC3, I cannot copy files to SMB
mounted directories any more. The files are created, but their size is
0 bytes, the copy command hangs and the message log shows:

Nov 22 13:04:54 sky kernel: smb_trans2: invalid data, disp=0, cnt=0,
tot=0, ofs=0

Going back to kernel 2.6.9-1.678_FC3 fixes the problem. The directory
in cause is mounted using smbmount, from CIFS Unix SMB shares (I tried
with two different ones). Was there any SMB chages in the latest
kernel update?


Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Install kernel-2.6.9-1.681_FC3
2. smbmount a SMB share
3. copy a file to it   

Actual Results:  file is created, with size 0 bytes, and the copy
command hangs

Expected Results:  file should be successfully copied to teh destination

Additional info:
Comment 1 Eric Hartmann 2004-11-24 10:39:37 EST
I experience the same troubles. However the file is copied but it
takes one minute to really start copying the file.

With kernel 667, I have no trouble.

I have same errors as Cornea in message.log: 

Nov 23 04:02:13 ehartmann mount.smbfs[2625]: [2004/11/23 04:02:13, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:13 ehartmann mount.smbfs[2625]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 117
ltype=0 (Bad file descriptor)
Nov 23 04:02:13 ehartmann mount.smbfs[2625]: [2004/11/23 04:02:13, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:13 ehartmann mount.smbfs[2625]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 117
ltype=1 (Bad file descriptor)
Nov 23 04:02:13 ehartmann mount.smbfs[2625]: [2004/11/23 04:02:13, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:13 ehartmann mount.smbfs[2625]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 117
ltype=1 (Bad file descriptor)
Nov 23 04:02:16 ehartmann kernel: SMB connection re-established (-5)
Nov 23 04:02:16 ehartmann mount.smbfs[2628]: [2004/11/23 04:02:16, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:16 ehartmann mount.smbfs[2628]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 117
ltype=0 (Bad file descriptor)
Nov 23 04:02:16 ehartmann mount.smbfs[2628]: [2004/11/23 04:02:16, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:16 ehartmann mount.smbfs[2628]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 117
ltype=1 (Bad file descriptor)
Nov 23 04:02:16 ehartmann mount.smbfs[2628]: [2004/11/23 04:02:16, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:16 ehartmann mount.smbfs[2628]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 117
ltype=1 (Bad file descriptor)
Nov 23 04:02:16 ehartmann kernel: SMB connection re-established (-5)
Nov 23 04:02:16 ehartmann mount.smbfs[2640]: [2004/11/23 04:02:16, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:16 ehartmann mount.smbfs[2640]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 89 ltype=1
(Bad file descriptor)
Nov 23 04:02:16 ehartmann mount.smbfs[2640]: [2004/11/23 04:02:16, 0]
tdb/tdbutil.c:tdb_log(725)
Nov 23 04:02:16 ehartmann mount.smbfs[2640]:  
tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 89 ltype=1
(Bad file descriptor)
Nov 23 04:02:16 ehartmann kernel: SMB connection re-established (-5)

Comment 2 Oliver Van Assche 2004-11-30 11:55:09 EST
I have been having the same problem when trying to save files with
kernel 2.6.9-1.681_FC3 :

Nov 30 17:14:12 multi kernel: smb_add_request: request [0ad73ca0,
mid=37099] timed out!
Nov 30 17:20:45 multi kernel: smb_trans2: invalid data, disp=0, cnt=0,
tot=0, ofs=0
Nov 30 17:21:15 multi kernel: smb_add_request: request [0ad73ca0,
mid=1763] timed out!
Nov 30 17:21:19 multi kernel: smb_trans2: invalid data, disp=0, cnt=0,
tot=0, ofs=0
Nov 30 17:21:49 multi kernel: smb_add_request: request [0ad73ca0,
mid=4044] timed out!

So i now am using kernel version 2.6.9-1.678_FC3 where the bug does
not appear.


Comment 4 Ed Holden 2004-12-03 17:54:21 EST
*** Bug 141365 has been marked as a duplicate of this bug. ***
Comment 5 Eric Hartmann 2004-12-07 02:58:55 EST
I've installed kernel-2.6.9-1.698_FC3 and everything works fine now.
Thanks !
Comment 6 Jesse Keating 2004-12-14 19:35:31 EST
I'm having problems with the 2.6.9 kernel that was pushed to FC2
updates, and I fear it is the exact same problem as described above. 
Can whatever was fixed in the FC3 kernel be pushed to the FC2 kernels
as well?
Comment 7 Dave Jones 2004-12-15 12:06:24 EST
should be fixed in the fc2 kernel in updates-testing.
Comment 8 Dave Jones 2005-07-15 14:38:02 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 9 Eric Hartmann 2005-07-15 16:48:00 EDT
I've upgraded to fc4 and I have no trouble with fc4.

Note You need to log in before you can comment on or make changes to this bug.