Bug 140493 - After shutdown, closing lid of laptop turns it back on
After shutdown, closing lid of laptop turns it back on
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 22:11 EST by Eric Smith
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 21:32:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Smith 2004-11-22 22:11:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When I shut down my laptop (either from Gnome, or "shutdown -h now"),
it shuts down, but then when I close the lid, it immediately starts up
again.  This just started happening when I upgraded from FC2 to FC3. 
I don't know that it's a kernel problem, but I'm not sure what other
component could cause this, though it seems likely that ACPI is involved.

If I shut down then press the "lid closed" button with my finger, it
powers up.  So it's definitely the "lid closed" button that is doing it.

But I'm certain that it's not a hardware fault, because when I boot
Windows XP then shut down, the "lid closed" button does NOT cause a
power-up.

I've tried the 2.6.9-1.678 and 2.6.9-1.681 update kernels, and they
exhibit the same problem.

I tried resetting BIOS settings to factory default, but that didn't
help.  I tried disabling the "suspend on close" BIOS setting, but that
didn't help either.

The laptop is a Fujitsu Lifebook P2040, which uses an 800 MHz
Transmeta Crusoe TM5800 CPU.  Fujitsu does not provide any BIOS
upgrades for this laptop, but I'm pretty sure it's not a BIOS problem
since it only has this problem after booting FC3, and not after
booting FC2 or Windows XP.

In order to close the laptop without it powering up, I now have to
shut it down, pull the batteries, close the lid, then reinsert the
batteries.


Version-Release number of selected component (if applicable):
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/os/Fedora/RPMS/kernel-2.6.9-1.667.i586.rpm

How reproducible:
Always

Steps to Reproduce:
1.  /sbin/shutdown -h now
2.  close lid or press "lid closed" switch with finger

    

Actual Results:  computer powers up

Expected Results:  computer should stay powered down

Additional info:
Comment 1 Eric Smith 2004-11-22 22:23:57 EST
Someone else had an almost identical problem, except that for him it
only happens if external power is applied, while for mine that doesn't
matter.  It's in this thread, under the subject "another problem", and
later in the thread there's a comment "2.6.9, ACPI bug, reboot on
shutdown" with a link to a patch that is claimed to fix it, but which
I haven't yet tried.

http://kerneltrap.org/node/view/4173

The comment links to this bug at OSDL.org:

http://bugme.osdl.org/show_bug.cgi?id=3669

However, the description of that bug does not match what I'm
experiencing, because they apparently have the computer power up when
they shutdown, without closing the lid.  Still, I'll give the patch a try.

Comment 2 Eric Smith 2004-11-23 19:15:16 EST
I've verified that David Shaohua's patch of 21-Nov-2004 fixes the
problem with my Fujitsu Lifebook.  Can you please add it to the next
Fedora Core 3 update kernel?

http://bugme.osdl.org/attachment.cgi?id=4105&action=view
Comment 3 Eric Smith 2005-01-10 21:26:17 EST
The problem seems to be fixed in kernel-2.6.10-1.737_FC3.

Note You need to log in before you can comment on or make changes to this bug.