Bug 140510 - Problems adding a new system
Problems adding a new system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Max Spevack
https://rhn.redhat.com/network/system...
:
Depends On:
Blocks: 147875
  Show dependency treegraph
 
Reported: 2004-11-23 04:11 EST by Jose Manuel Garcia
Modified: 2007-10-23 22:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-17 12:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jose Manuel Garcia 2004-11-23 04:11:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
Hi.

I have a problem.
I tried to add a new system to red hat network for getting new updates.
I tried several times, because i had problems with my proxy
configuration. When i tried to update the machine using up2date it
gave me an error:

up2date_client.up2dateErrors.CommunicationError: Error communicating
with server. The message was:
Conexión rehusada
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 416, in
onPrivacyPagePrepare
    rhnreg.getCaps()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 204, in getCaps
    rpcServer.doCall(s.registration.welcome_message)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 121, in doCall
    raise up2dateErrors.CommunicationError(e.args[1])

After several tries i login into rhn to look for the system
entitlements and i saw that the same machine was added 3 times and i
had only support for 3 machines. 
I need to reset the entitlements to only had the previously added
machine and only have the last machine i added one time, because i
will need to add a 3rd machine.

I want to know why i get this

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. up2date --register
I used my login: cedujccm and the password i have previously obtain in
red hat network after the registration of my first machine with my red
hat enterprise AS 3.0 registration number.

Error obtained:
up2date_client.up2dateErrors.CommunicationError: Error communicating
with server. The message was:
Conexión rehusada
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 416, in
onPrivacyPagePrepare
    rhnreg.getCaps()
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 204, in getCaps
    rpcServer.doCall(s.registration.welcome_message)
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 121, in doCall
    raise up2dateErrors.CommunicationError(e.args[1])
I change the configuration of my proxy and my system seems to be
added, but after send all the info about my system i got the following
error:
Error Message:
    Service not enabled for system profile: "EDUFILES"
Error Class Code: 31
Error Class Info: 
     This system does not have a valid entitlement for Red Hat Network.
     Please visit https://rhn.redhat.com/network/systems/entitlements.pxt
     or login at https://rhn.redhat.com, and from the "Systems" tab,
     select "System Entitlements" to enable RHN service for this system.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

2. up2date 
Now when i try to run up2date it tries to add my machine another time
and when the registration is finished i got the previous error.

3.
    

Actual Results:  Now when i try to update the system edufiles i get
this error:

Error Message:
    Service not enabled for system profile: "EDUFILES"
Error Class Code: 31
Error Class Info: 
     This system does not have a valid entitlement for Red Hat Network.
     Please visit https://rhn.redhat.com/network/systems/entitlements.pxt
     or login at https://rhn.redhat.com, and from the "Systems" tab,
     select "System Entitlements" to enable RHN service for this system.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Expected Results:  The system should be updated and i don't need the
same machine added for 3 times.

Additional info:
Comment 1 Mihai Ibanescu 2005-05-17 12:03:39 EDT
Oh, sorry for the late reply.
Closing, I believe it's fixed in the latest release. Please reopen if it still
happens.

Note You need to log in before you can comment on or make changes to this bug.