Bug 140567 - gftp crashes when file download attempt is made
gftp crashes when file download attempt is made
Product: Fedora
Classification: Fedora
Component: gftp (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
: 124650 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2004-11-23 12:36 EST by Todd Higginbotham
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-30 23:47:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot of ddd at point of crash (87.23 KB, image/png)
2005-01-25 14:18 EST, Art Wagner
no flags Details
The last 1000 lines from strace. (60.96 KB, text/plain)
2005-01-26 06:45 EST, Bob Chiodini
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 160813 None None None Never

  None (edit)
Description Todd Higginbotham 2004-11-23 12:36:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
I attempted a file transfer from a remote ftp to my system.  I
selected the folder I wanted the file to go in the left pane of the
program, and selected the file I wanted to transfer on the right.  I
clicked the right arrow signifying the transfer and the program crashed.

I tried this again but instead dragged the fil from the right pane to
the left, with the same results.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Login to a FTP
2. Click a file on the right pane to download
3. Click the bottom arrow pointing left or drag the file to left pane

Actual Results:  Gftp crashed.

Expected Results:  For the file to transfer to the specified folder.

Additional info:
Comment 1 Oli Wade 2004-12-11 09:05:18 EST
Perhaps this is the same as bug 124650 for fc2 ?

I see the same behaviour (fc3, gftp 2.0.17) and have the following in
the kernel log:
   kernel: gftp-gtk[6575]: segfault at 00000000000000ff rip
0000000000439203 rsp 00000000409fd160 error 6
Comment 2 Jan-Petter Vainionpaa 2004-12-28 19:19:17 EST

Same happens here, I have Fedora Core 3 amd64 release and the version
of gftp is:


I got following output to shell when gftp crashed (having launched
gftp from shell):

(gftp-gtk:4581): Gtk-CRITICAL **: file gtktextbuffer.c: line 557
(gtk_text_buffer_emit_insert): assertion `g_utf8_valida te (text, len,
NULL)' failed

It was repeated four times. Also same segfault reported to kernel logs.
Comment 3 Warren Togami 2004-12-29 23:23:19 EST
*** Bug 124650 has been marked as a duplicate of this bug. ***
Comment 4 Art Wagner 2005-01-24 22:02:47 EST
I get similar result but messages log is different. My shell als
reports "segfault" and my messages log is aa follows:
Jan 24 13:38:17 arjuna kernel: gftp-gtk[23508]: segfault at
00000000000000ff rip 0000000000439203 rsp 00000000409fe160 error 6 
I am running kernel-2.6.10-1.741-x86_64 but get the same failure with 
a previous kernel-2.6.9-1.667 left over from a previous install. The
transition to FC3-final was via Upgrade.
Comment 5 Art Wagner 2005-01-25 14:18:37 EST
Created attachment 110209 [details]
screenshot of ddd at point of crash

Includes information from dump of gFTP-gtk at crash
Comment 6 Art Wagner 2005-01-25 14:20:00 EST
I am not a programmer but I did get this info with DDD
Comment 7 Bob Chiodini 2005-01-26 06:45:14 EST
Created attachment 110241 [details]
The last 1000 lines from strace.

The strace is available, but is ~850K.	If it's needed let me know.
Comment 8 Vaclav "sHINOBI" Misek 2005-01-27 06:55:25 EST
It seems to be a duplicate of http://bugs.gnome.org/show_bug.cgi?id=160813
This problem is solved with the latest test version of gftp
http://www.gftp.org/gftp-test.tar.bz2 (from 27. 01. 2005) for me, but
errata package from fedora will be appreciated :-).
Comment 9 Art Wagner 2005-01-27 18:02:51 EST
Vaclav's fix did indeed fix my problem. I downloaded and compiled the
update and my system now downloads fine. I do agree a updated package
from Fedora would be of much assistance to any who don't feel able to
compile a package and install it The gftp-test.tar.bz2 reports itself
to be 2.0.18-rc1 but I do not know if if is a patched version?
Comment 10 Matthew Miller 2006-07-10 18:02:44 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 11 John Thacker 2006-10-30 23:47:00 EST
Fixed in FC4 and forwards by gftp-2.0.18
Since FC3 is maintained only for security updates, this can be closed.  Sorry a
backported update was never released for FC3.

Note You need to log in before you can comment on or make changes to this bug.