Bug 140679 - Updating gamin from 0.0.15 to 0.0.17 fails due to libfam.so.0 dependency
Updating gamin from 0.0.15 to 0.0.17 fails due to libfam.so.0 dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
: 149799 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 01:54 EST by Nigel Tao
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 17:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Tao 2004-11-24 01:54:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
Cannot update gamin to 0.0.17 - possibly a x86_64 thing?

[root@obelisk ~]# yum clean all

...

[root@obelisk ~]# yum update
Setting up Update Process
Setting up Repo:  base
repomd.xml                100% |=========================| 1.1 kB    00:00
Setting up Repo:  updates-released
repomd.xml                100% |=========================|  951 B    00:00
Reading repository metadata in from local files
base      : ################################################## 2852/2852
primary.xml.gz            100% |=========================|  94 kB    00:02
MD Read   : ################################################## 241/241
updates-re: ################################################## 241/241
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gamin-devel to pack into transaction set.
gamin-devel-0.0.17-1.FC3. 100% |=========================| 4.8 kB    00:00
---> Package gamin-devel.x86_64 0:0.0.17-1.FC3 set to be updated
---> Downloading header for gamin to pack into transaction set.
gamin-0.0.17-1.FC3.x86_64 100% |=========================| 7.5 kB    00:00
---> Package gamin.x86_64 0:0.0.17-1.FC3 set to be updated
--> Running transaction check
--> Processing Dependency: libfam.so.0 for package: gnome-vfs2
--> Finished Dependency Resolution
Error: Missing Dependency: libfam.so.0 is needed by package gnome-vfs2

[root@obelisk ~]# rpm -q gamin gnome-vfs2
gamin-0.0.15-1
gnome-vfs2-2.8.2-8
gnome-vfs2-2.8.2-8

[root@obelisk ~]# ls /usr/lib64/libfam.so.0
/usr/lib64/libfam.so.0

[root@obelisk ~]# ls /usr/lib/libfam.so.0
ls: /usr/lib/libfam.so.0: No such file or directory


Version-Release number of selected component (if applicable):
0.0.15

How reproducible:
Always
Comment 1 Daniel Veillard 2004-11-25 10:31:49 EST
This is an x86_64 specific problem. I think gnome-vfs2 should be
fixed to require fam or gamin directly,

Daniel
Comment 3 gene smith 2005-01-12 22:00:45 EST
Problem now seem to be resolved. Yum -y update (with no exclusions)
updated the gamin items no dependency errors.
Comment 4 Scott DeVos 2005-02-02 16:34:35 EST
No, it is not fixed.  I just did a fresh-brand-spankin'-new install of
FC3 x86_64 and I cannot run yum update due to this very error.
Comment 5 Scott DeVos 2005-02-02 16:47:13 EST
OK, here is what fixed this problem for me:

# wget
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/i386/gamin-0.0.17-1.FC3.i386.rpm
# rpm -Uvh gamin-0.0.17-1.FC3.i386.rpm
# yum -y update

This worked (at least it got past the dependency checks--I'm still
waiting for the downloads to finish.
Comment 6 Aaron VanDevender 2005-02-15 11:07:51 EST
I would consider this a workaround and not a fix. Having to manually download
and install a package from a yum repository in order to get yum to work kind of
defeats the purpose of having yum. The real question is why wasn't the i386
version of gamin intstalled to begin with and why wasn't the dependancy resolver
able to see that gamin-i386 satisfied gnome-vfs2's libfam.so requirement?

I see this as a problem which is likley to pop up in other places in the x86_64
world down the road and so it would be wise to track this down and address it
across the board as early as possible.
Comment 7 Rob King 2005-02-27 13:13:56 EST
*** Bug 149799 has been marked as a duplicate of this bug. ***
Comment 8 Michael Gilchrist 2005-04-01 12:56:40 EST
The previous address given for getting gamin-0.0.17 is no longer valid.  I found
the appropriate rpm at: 
http://frontier.eas.asu.edu/updates/old/heidelberg/i386/gamin-0.0.17-1.FC3.i386.rpm
Comment 9 John Thacker 2006-04-22 17:01:02 EDT
"The real question is why wasn't the i386
version of gamin intstalled to begin with"

This was the problem.  Both the x86 and x86-64 versions of gnome-vfs2 
were installed initially, but only the x86-64 version of gamin.  This
meant that some dependencies were not satisfied right off the bat, 
before any updates were done, and yum was complaining about the 
unmet dependencies.  It's more a problem with the initial installer.

This should already be fixed in later Fedora Core releases.  Since FC3 is
officially under the care of Fedora Legacy and this is not a security
issue (and new installs of FC3 should be rare), closing.

Note You need to log in before you can comment on or make changes to this bug.