Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 140689 - Beta bugzille keeps asking me to login
Beta bugzille keeps asking me to login
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 04:03 EST by John Summerfield
Modified: 2007-05-02 12:50 EDT (History)
0 users

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 16:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Summerfield 2004-11-24 04:03:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040809 Epiphany/1.3.8

Description of problem:
I attempted to use the beta version of bz. However after each page it
asked me to login again.

I'm using the same settings, browser etc as for the production version
and that works.

Version-Release number of selected component (if applicable):
beta

How reproducible:
Always

Steps to Reproduce:
1.N/a
2.
3.
    

Additional info:

Check logs for accesses from 220.235.57.95 (proxied via
westnet.com.au) to see what I did.
Comment 1 David Lawrence 2004-11-24 11:03:45 EST
Wierd, I do not see that behavior. Can you please clear out all
bugzilla.redhat.com cookies from your browsers cookie history and try the same
operations to see if it no longer asks you to login for each page?
Comment 2 John Summerfield 2004-11-24 18:51:40 EST
I changed browser.
I'm running Nahant-1 and had not previously used Firefox.
I started off https://bugzilla.redhat.com/beta/easy_enter_bug.cgi
I clicked step 3
I logged in
I selected bz, step 4
I now login again
I check cookies, see two, remove them.
I choose the latest release (How should _I_ know?) and all arches.
Click additional info
Login (expected)
"Bogus bug bug" and random text.
Submit
New window opens (please don't) and I'm invited to login.
Comment 3 John Summerfield 2004-11-24 19:02:45 EST
What the hell!
Clearing cookies in Firefox appears to have cleared cookies in Epiphany too. E
got a login screen.


I tried to login again in Firefox and got this:
Invalid Email Address  
The e-mail address you entered () didn't pass our syntax checking for a legal
email address. A legal address must contain exactly one '@', and at least one
'.' after the @. It must also not contain any of these special characters:\ ( )
& < > , ; : " [ ], or any whitespace.

for this email address
debian@herakles.homelinux.org

I retried by clicking login again and submitted my bogus bug bug.

Which I closed without having to login again again again...


Comment 4 John Summerfield 2004-11-24 19:05:11 EST
I should mention that I erased two bz cookies; now I have three.
Comment 5 John Summerfield 2004-11-26 18:12:56 EST
The problem has recurred. I've done nothing to my cookie collection
since the previous reports.
Comment 6 David Lawrence 2004-11-27 18:56:37 EST
It might have had something to with a misconfigured redirect on our server side.
Going to http://bugzilla.redhat.com/beta was not set to redirect to
https://bugzilla.redhat.com/beta which will cause cookie problems since they are
considered different. All http: should become https: now. Please try to remove
the bugzilla.redhat.com cookies and see if this clears up.

Note You need to log in before you can comment on or make changes to this bug.