Bug 140705 - totem crashes
totem crashes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 07:35 EST by Thilo Pfennig
Modified: 2013-03-13 00:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-15 15:35:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thilo Pfennig 2004-11-24 07:35:02 EST
Description of problem:

There are many different situations when totem crashes. This came
after updateing to FC3 (before that it only had performance problems).
After playinf for a while totem does not accept any more files to be
added to the playlist.

It gives iut the following:
"(totem:4735): GLib-GObject-CRITICAL **: file gvaluetypes.c: line 785
(g_value_get_string): assertion `G_VALUE_HOLDS_STRING (value)' failed
"

it continues playing, but when I try to close the playlist it suggest
to close the whole totem.


Version-Release number of selected component (if applicable):

0.99.19

How reproducible:

Allways

Steps to Reproduce:
1. open laylist window of totem.
2. put some music files in the playlist window
3. play the list.
4. add more files
  
Actual results:

totem crashes

Expected results:

continuous playing.
Comment 1 Bastien Nocera 2005-05-10 17:39:34 EDT
Could you please run "totem --g-fatal-warnings" and reproduce the bug?
This should give you the full backtrace in bug-buddy.
Comment 2 Thilo Pfennig 2005-05-11 06:12:25 EDT
totem --g-fatal-warnings  

GLib-GObject-WARNING **: invalid (NULL) pointer instance
aborting...

this was a fast crash without doing *anything*!
Comment 3 Thilo Pfennig 2005-05-11 06:13:57 EDT
Backtrace was generated from '/usr/bin/totem'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...[Thread debugging
using libthread_db enabled]
[New Thread -1208408384 (LWP 5685)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...(no debugging symbols found)...(no
debugging symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...0x00a177a2 in _dl_sysinfo_int80 () from
/lib/ld-linux.so.2
#0  0x00a177a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x00c7e2f3 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x02c93f50 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x00a177a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#5  0x00a587d5 in raise () from /lib/tls/libc.so.6
#6  0x00a5a149 in abort () from /lib/tls/libc.so.6
#7  0x00d3ff7e in g_logv () from /usr/lib/libglib-2.0.so.0
#8  0x00d3ffb0 in g_log () from /usr/lib/libglib-2.0.so.0
#9  0x0012c504 in g_type_check_instance () from /usr/lib/libgobject-2.0.so.0
#10 0x0011d50b in g_signal_connect_data () from /usr/lib/libgobject-2.0.so.0
#11 0x080600fc in bacon_video_widget_new ()
#12 0x08066b74 in totem_action_exit ()
#13 0x08069c49 in main ()

Thread 1 (Thread -1208408384 (LWP 5685)):
#0  0x00a177a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x00c7e2f3 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x02c93f50 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x00a177a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#5  0x00a587d5 in raise () from /lib/tls/libc.so.6
No symbol table info available.
#6  0x00a5a149 in abort () from /lib/tls/libc.so.6
No symbol table info available.
#7  0x00d3ff7e in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x00d3ffb0 in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x0012c504 in g_type_check_instance () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0x0011d50b in g_signal_connect_data () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0x080600fc in bacon_video_widget_new ()
No symbol table info available.
#12 0x08066b74 in totem_action_exit ()
No symbol table info available.
#13 0x08069c49 in main ()
No symbol table info available.
Comment 4 John (J5) Palmieri 2005-05-11 09:57:20 EDT
You also need to install the debuginfo packages for totem and perhaps gtk so
that we can see debuging symbols.
Comment 5 John (J5) Palmieri 2005-05-11 10:00:52 EDT
ignore the above comment.  Looks like you do have debug info.
Comment 6 John Thacker 2006-04-15 11:40:50 EDT
Is this still reproducible with FC5, and totem-1.4.0?  There have been a lot of
updates and changes, especially to totem, since FC3.
Comment 7 Thilo Pfennig 2006-04-15 14:27:05 EDT
no
Comment 8 John Thacker 2006-04-15 15:35:51 EDT
Problem solved, closing.

Note You need to log in before you can comment on or make changes to this bug.