Bug 140706 - httpd fails to start from a server install
httpd fails to start from a server install
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 07:35 EST by Paul F. Johnson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 16:24:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2004-11-24 07:35:43 EST
Description of problem:
After a fresh install and with server options selected, httpd fails to
start

Version-Release number of selected component (if applicable):
2.0.52-3.1

How reproducible:
Always

Steps to Reproduce:
1. Either reboot or issue from the command line /etc/init.d/httpd start
2.
3.
  
Actual results:
Starting httpd: /usr/sbin/httpd: error while loading shared libraries:
libpcre.so.0: cannot open shared object file: Permission denied 

Expected results:
httpd should start

Additional info:
I have attemted to create a fresh symlink, reinstall pcre, run
restorecon and also prelink manually to cure the problem, they haven't
worked.
Comment 1 Joe Orton 2004-11-24 09:50:11 EST
This is probably because the files have lost their SELinux labelleing.
 This was a fresh FC3 install?

Running "restorecon /usr/lib/libpcre.so.*" should be sufficient, if
you find more labels are wrong, it may be necessary to do "fixfiles
restore".

Note You need to log in before you can comment on or make changes to this bug.