Bug 140714 - unzip crashes (segfault) on large zipfile
unzip crashes (segfault) on large zipfile
Status: CLOSED DUPLICATE of bug 134073
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: unzip (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Ben Levenson
:
Depends On:
Blocks: 140583
  Show dependency treegraph
 
Reported: 2004-11-24 08:21 EST by Johan Walles
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Walles 2004-11-24 08:21:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sv-SE; rv:1.6) Gecko/20040113

Description of problem:
I have a 69Mb zipfile.  "unzip" crashes when trying to extract a
symlink from that file.  The zipfile can be provided upon request; I
felt it's a bit too big to be attached to this bug, but I can attach
it if you want.

Using unzip on the same file from unzip-5.50-30 / RHAS21 on the same
machine works fine.


Version-Release number of selected component (if applicable):
unzip-5.51-4

How reproducible:
Always

Steps to Reproduce:
johan@sthqa04:/localhome/johan/clients/johan/ariane$ unzip
20041124-1405jdk-1_4_2_05-fcs-bin-b04-linux-i586-03_jun_2004.zip


Actual Results:  Archive: 
20041124-1405jdk-1_4_2_05-fcs-bin-b04-linux-i586-03_jun_2004.zip
   creating: jdk1.4.2_05/
   creating: jdk1.4.2_05/jre/
   creating: jdk1.4.2_05/jre/bin/
  inflating: jdk1.4.2_05/jre/bin/java
  inflating: jdk1.4.2_05/jre/bin/keytool
  inflating: jdk1.4.2_05/jre/bin/policytool
  inflating: jdk1.4.2_05/jre/bin/kinit
  inflating: jdk1.4.2_05/jre/bin/klist
  inflating: jdk1.4.2_05/jre/bin/ktab
  inflating: jdk1.4.2_05/jre/bin/rmiregistry
  inflating: jdk1.4.2_05/jre/bin/rmid
  inflating: jdk1.4.2_05/jre/bin/orbd
  inflating: jdk1.4.2_05/jre/bin/servertool
  inflating: jdk1.4.2_05/jre/bin/tnameserv
  inflating: jdk1.4.2_05/jre/bin/ControlPanel
  inflating: jdk1.4.2_05/jre/bin/java_vm
  inflating: jdk1.4.2_05/jre/bin/java_g
  inflating: jdk1.4.2_05/jre/bin/keytool_g
  inflating: jdk1.4.2_05/jre/bin/kinit_g
  inflating: jdk1.4.2_05/jre/bin/klist_g
  inflating: jdk1.4.2_05/jre/bin/ktab_g
  inflating: jdk1.4.2_05/jre/bin/orbd_g
  inflating: jdk1.4.2_05/jre/bin/policytool_g
  inflating: jdk1.4.2_05/jre/bin/rmid_g
  inflating: jdk1.4.2_05/jre/bin/rmiregistry_g
  inflating: jdk1.4.2_05/jre/bin/servertool_g
  inflating: jdk1.4.2_05/jre/bin/tnameserv_g
   creating: jdk1.4.2_05/jre/lib/
   creating: jdk1.4.2_05/jre/lib/applet/
   creating: jdk1.4.2_05/jre/lib/i386/
   creating: jdk1.4.2_05/jre/lib/i386/native_threads/
  inflating: jdk1.4.2_05/jre/lib/i386/native_threads/libhpi.so
  inflating: jdk1.4.2_05/jre/lib/i386/native_threads/libhpi_g.so
   creating: jdk1.4.2_05/jre/lib/i386/server/
  inflating: jdk1.4.2_05/jre/lib/i386/server/libjvm.so
  inflating: jdk1.4.2_05/jre/lib/i386/server/Xusage.txt
    linking: jdk1.4.2_05/jre/lib/i386/server/libjsig.so  warning: 
symbolic link (jdk1.4.2_05/jre/lib/i386/server/libjsig.so) failed
error:  zipfile probably corrupt (segmentation violation)


Expected Results:  The zip file should have been fully extracted. 
"unzip" shouldn't be talking about segmentation violations.


Additional info:

/etc/redhat-release says:
Red Hat Enterprise Linux AS release 3.90 (Nahant)

unzip -v says:

UnZip 5.51 of 22 May 2004, by Info-ZIP.  Maintained by C. Spieler.  Send
bug reports using http://www.info-zip.org/zip-bug.html; see README for
details.
 
Latest sources and executables are at
ftp://ftp.info-zip.org/pub/infozip/ ;
see ftp://ftp.info-zip.org/pub/infozip/UnZip.html for other sites.
 
Compiled with gcc 3.4.0 20040613 (Red Hat Linux 3.4.0-5) for Unix
(Linux ELF) on Jun 22 2004.
 
UnZip special compilation options:
        COPYRIGHT_CLEAN (PKZIP 0.9x unreducing method not supported)
        LZW_CLEAN (PKZIP/Zip 1.x unshrinking method not supported)
        SET_DIR_ATTRIB
        TIMESTAMP
        USE_EF_UT_TIME
        USE_DEFLATE64 (PKZIP 4.x Deflate64(tm) supported)
        VMS_TEXT_CONV
        [decryption, version 2.9 of 05 May 2000]
 
UnZip and ZipInfo environment options:
           UNZIP:  [none]
        UNZIPOPT:  [none]
         ZIPINFO:  [none]
      ZIPINFOOPT:  [none]
Comment 2 Lon Hohberger 2004-11-29 10:20:00 EST
It's not the size of the zip file; it's got to do with symbolic links
inside the zip file.

*** This bug has been marked as a duplicate of 134073 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.