Bug 140729 - makewhatis located in /usr/bin and not in /usr/sbin
Summary: makewhatis located in /usr/bin and not in /usr/sbin
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: man   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 154177 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-24 15:29 UTC by Kjell Arne Rekaa
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-17 13:05:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjell Arne Rekaa 2004-11-24 15:29:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The man documentation of whatis(1) tells the following in the 
DESCRIPTION
...
The whatis database is created using the command /usr/sbin/makewhatis.
...

But the makewhatis IS NOT located in /usr/sbin:
# which makewhatis
/usr/bin/makewhatis

Since the the man page of makewhatis(8) clearly put the command in
section 8 (manager specific) it does make sense to actually put the
makewhatis program/script in /usr/sbin.


My Fedore Core 2 is last updated 23-nov-2004:

uname -a
Linux konqueror.sds.no 2.6.9-1.6_FC2smp #1 SMP Thu Nov 18 22:20:16 EST
2004 i686 i686 i386 GNU/Linux

Kjell Arne

Version-Release number of selected component (if applicable):
man-1.5o1-6.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. man whatis | egrep makewhatis
2. which makewhatis
3. (Note the difference...)
    

Actual Results:  
# which makewhatis
/usr/bin/makewhatis


Expected Results:  
# which makewhatis
/usr/sbin/makewhatis


Additional info:

Comment 1 Ivana Varekova 2005-03-16 09:30:00 UTC
Thank you for your notice.
It was be fixed (in man-1.5p-2).
Ivana Varekova 

Comment 2 Ivana Varekova 2005-04-08 07:33:35 UTC
*** Bug 154177 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.