Bug 140733 - Adding new printer (HP 2550Ln) with PPD file fails
Adding new printer (HP 2550Ln) with PPD file fails
Status: CLOSED DUPLICATE of bug 132625
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
http://www.linuxprinting.org/download...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 10:46 EST by David Anderson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 10:09:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Anderson 2004-11-24 10:46:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3) (KHTML, like Gecko)

Description of problem:
I have a new HP Colour LaserJet 2550Ln.

I obtained a PPD from it from:

http://www.linuxprinting.org/download/PPD/HP/color_laser/HP_Color_LaserJet_2550.ppd

I imported this into system-config-printer (how this works isn't obvious, by the way - I first thought that you had to create a Generic Postscript printer, then select it and import PPD... a bit of Googling discovered that I had to import PPD, and _then_ the printer should be available. Suggestion: Add a "Use PPD" or "I have a PPD" button to the driver selection screen of the new printer wizard).

I then created a new printer, selecting the now-present printer driver (something like "HP Color LaserJet 2550Ln (PPD)").
When I click the final button in the wizard, nothing happens, but my Konsole (from which I ran s-c-p) has this output:

Traceback (most recent call last):
  File "/usr/share/printconf/util/addQueue.py", line 1251, in finish
    self.queue_data, driver_tuple)
  File "/usr/share/printconf/util/printconf_conf.py", line 968, in construct_queue
    printer.id, gs_driver)
  File "/usr/share/printconf/util/printconf_conf.py", line 807, in foomatic_set_default_page_size
    for opt in drv.options.values():
AttributeError: 'NoneType' object has no attribute 'options'


I then installed the thing happily from http://localhost:631/ with no hiccups, but as a good community member I'm doing my duty and letting you know about the bug! :-)

My printer's connected via USB.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.98-1

How reproducible:
Always

Steps to Reproduce:
1. Load system-config-printer 
2. Download and import http://www.linuxprinting.org/download/PPD/HP/color_laser/HP_Color_LaserJet_2550.ppd
3. Try to add a new printer based on this PPD

    

Actual Results:  Nothing happens at final stage of wizard. Traceback appears on stdout.

Expected Results:  Printer installs.

Additional info:

Works fine installing via CUPS interface on port 631.
Comment 1 Tim Waugh 2004-11-27 10:55:54 EST
Could you try again with foomatic-3.0.1-3.2 installed?:

  ftp://people.redhat.com/twaugh/tmp/foomatic-fc2/

Thanks.
Comment 2 David Anderson 2004-11-30 13:51:27 EST
Tried it - it was worse! 
 
This time the printer didn't even show up in the list of HP printers, 
so I was stuck at the "choose driver" stage. 
 
I tried this twice, then rolled back to the previous foomatic and 
verified that the printer showed up again. 
Comment 3 Tim Waugh 2004-12-01 04:44:59 EST
Hmm.  How about if you do this?:

rpm -e foomatic --nodeps
rm -rf /usr/share/foomatic
rpm -ivh foomatic-3.0.1-3.2.i386.rpm

Then re-import the PPD.  I think it might have been that the original PPD import
was still causing problems.
Comment 4 David Anderson 2004-12-07 07:06:42 EST
Nope, same problem - the imported PPD doesn't show up in the list of HP 
printers. (Does it for you?) 
Comment 5 Tim Waugh 2004-12-09 08:38:36 EST
Yes, it does for me with the current development packages:

Color LaserJet 2550 Series (PPD)

Are you still getting a traceback?
Comment 6 David Anderson 2004-12-10 09:28:44 EST
No, I don't get to the final stage of the "add printer" wizard, 
because "Color LaserJet 2550 Series (PPD)" never shows up in my list 
of printers when I choose manufacturer "HP" with the new foomatic (it 
does show up with the old). 
 
Comment 7 Tim Waugh 2004-12-10 09:33:27 EST
If you start system-config-printer from a gnome-terminal window and import the
PPD again, what messages appear on the terminal?
Comment 8 David Anderson 2004-12-10 09:36:48 EST
I've just tried the new package on my other FC2 machine (both were  
having the traceback before), and it works - no traceback, printer  
shows up. This is after I remove the foomatic directory.  
  
I'll try to find a moment to try it again on the one that's failing  
and see if I'm going mad or not (I tried it twice, just to be  
sure...).  
  
Even so, though, if the fix only works if people remove their  
foomatic directories, there's still something that needs resolving,  
isn't there? I've kept my old foomatic directory on both machines in  
case you release anything else that needs testing.  
  
Comment 9 David Anderson 2004-12-10 09:38:21 EST
Here are the messages that appears on my konsole when importing the 
PPD _on the machine where it works_ : 
 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-ColorModel.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-ManualFeed.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-PageSize.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPManualDuplex.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-InputSlot.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-MediaType.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPColorSmart.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPEdgeControl.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPRGBEmulation.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPPhotoNeutralGrays.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPPhotoHalftone.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPGraphicsNeutralGrays.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPGraphicsHalftone.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPTextNeutralGrays.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPTextHalftone.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmTextColor.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmTextStyle.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmTextAngle.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmFontSize.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmFontName.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmTextMessage.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmPages.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPCMYKInks.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd5-HPwmSwitch.xml 
Reading /usr/share/foomatic/db/source/driver/ppd.xml 
Writing /usr/share/foomatic/db/source/driver/ppd.xml 
 
(system-config-printer:17151): Gtk-CRITICAL **: file gtkwidget.c: 
line 3360 (gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT 
(widget, event)' failed 
 
(system-config-printer:17151): Gtk-CRITICAL **: file gtkwidget.c: 
line 3360 (gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT 
(widget, event)' failed 
Use of deprecated SAXv1 function endElement 
 
 
(I'm not sure if those last ones came up at the same time, or later). 
Comment 10 David Anderson 2004-12-10 10:01:48 EST
Hmmm, on that one that did work, I hadn't moved my foomatic directory 
out of the way - shown by the number "5" instead of "1". I've now 
done it with moving the directory, and it still works (1s instead of 
5s). 
 
I've now tested it on my other machine also, having moved the 
foomatic directory out of the way - and it works. No traceback, 
printer shows up. Then I tested it with the old foomatic directory in 
place - and it still works! 
That is extremely wierd. I tested it twice each, with and without the 
old foomatic directory in place before, and the thing didn't show up. 
I must be going crazy. 
 
So now, it does work, whether or not I have the old foomatic 
directory, and on both machines. 
 
Output from other machine with foomatic directory moved before 
installing the new RPM: 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-ColorModel.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-ManualFeed.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-PageSize.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPManualDuplex.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-InputSlot.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-MediaType.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPColorSmart.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPEdgeControl.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPRGBEmulation.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPPhotoNeutralGrays.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPPhotoHalftone.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPGraphicsNeutralGrays.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPGraphicsHalftone.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPTextNeutralGrays.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPTextHalftone.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmTextColor.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmTextStyle.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmTextAngle.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmFontSize.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmFontName.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmTextMessage.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmPages.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPCMYKInks.xml 
Writing /usr/share/foomatic/db/source/opt/ppd-ppd1-HPwmSwitch.xml 
Reading /usr/share/foomatic/db/source/driver/ppd.xml 
Writing /usr/share/foomatic/db/source/driver/ppd.xml 
 
BTW, last week you released a Fedora errata for something, and my 
e-mail client (kmail) said that the GPG signature was bad for the 
errata (I had installed your GPG key). Don't know if anyone else 
mentioned that to you. 
Comment 11 Tim Waugh 2004-12-10 10:09:18 EST
Great.

(GPG: Omni perhaps?  Works fine on the message I received.)

*** This bug has been marked as a duplicate of 132625 ***

Note You need to log in before you can comment on or make changes to this bug.