Bug 140787 - Updated rpms require hal-gnome without enforcing that requirement
Updated rpms require hal-gnome without enforcing that requirement
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Depends On:
  Show dependency treegraph
Reported: 2004-11-24 16:55 EST by dan ginsberg
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-01-03 14:12:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
list of packages updated by yum (16.82 KB, text/plain)
2004-11-24 16:57 EST, dan ginsberg
no flags Details

  None (edit)
Description dan ginsberg 2004-11-24 16:55:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
At some point, a dependency on hal-gnome was created but not enforced
in some gnome rpm.  I updated a bunch of rpm last night via yum and
suddenly gnome-volume-manager started crashing on desktop startup.   I
started working backwards and after installing hal-gnome, the problem
went away, but if hal-gnome was required, then yum should have caught
that dependency and installed it.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install fedora core 3 rc 2
2. verify that everything works
3.  yum update
4. log in
5. startx


Actual Results:  hal-gnome not installed

gnome-volume-manager crash popup window appears.  wont restart ( so no
nautilus, no desktop background, various badness trying to open files
from apps )

Expected Results:  1) yum catches all missing dependencies and
installs hal-gnome
2) gnome-volume-manager does not crash on x session startup

Additional info:
Comment 1 dan ginsberg 2004-11-24 16:57:26 EST
Created attachment 107428 [details]
list of packages updated by yum

This is the list of packages updated by yum.  One or more of these requires
hal-gnome but does not enforce that requirement.
Comment 2 David Zeuthen 2005-01-03 14:12:09 EST
I'm pretty sure no other packages require hal-gnome; I think what you
were seeing was the prelink issue (bug 140081) that was recently fixed.

Note You need to log in before you can comment on or make changes to this bug.