Bug 140797 - after starting haldaemon freezes the machine
after starting haldaemon freezes the machine
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 18:29 EST by Koenraad Heijlen
Modified: 2013-03-05 22:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 15:26:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
verbose output of hald 0.4.0 (27.71 KB, text/plain)
2004-11-24 18:34 EST, Koenraad Heijlen
no flags Details
verobose output of hald 0.4.1-snapshot (29.79 KB, text/plain)
2004-11-24 18:35 EST, Koenraad Heijlen
no flags Details

  None (edit)
Description Koenraad Heijlen 2004-11-24 18:29:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
When booting the haldaemon starts and a few seconds later the machine
freezes. This behaviour has been present since the FC3 release
(x86_64). I have not seen this in any of the i386 FC3-testX releases.
(I've tracked rawhide since test2).

Version-Release number of selected component (if applicable):
hal-0.4.0-10, hal-0.4.1.snapshot20041116-1

How reproducible:
Always

Steps to Reproduce:
1. boot the machine, starting hal is 'ok'
2. wait one second - a few seconds



Actual Results:  The machine is totally unresponsive. The keyboard
leds don't work, no network connectivity (no ping reply, no daemons work).

Expected Results:  Anything but a frozen machine.

Additional info:

I've tried it with all the different kernels since the release of FC3
up till 2.6.9-1.681_FC3. I tried booting with 'acpi=off' as boot
parameter : no change.  I've also tried the hal package pointed to in
bug 139819 : no change.

The last message in /var/log/messages with hal version 0.4.0-10 is:
Nov 24 18:21:08 mysterx haldaemon: haldaemon startup succeeded
Nov 24 18:21:10 mysterx fstab-sync[3370]: removed all generated mount
points

And with the 0.4.1-snapshot release:
kernel: 50-fstab-sync.h[3896] general protection rip:3d92359b2d
rsp:7fbffff810 error:0
Comment 1 Koenraad Heijlen 2004-11-24 18:34:50 EST
Created attachment 107433 [details]
verbose output of hald 0.4.0 

The verbose output generated while starting 'hald' made with this script:

hald --daemon=no --verbose=yes > hald_verbose 2>&1 &
tail hald_verbose &
while (true) ;	do
	sync &
done

(since it freezes the machine a few syncs to make sure I get as much as
possible).
Comment 2 Koenraad Heijlen 2004-11-24 18:35:17 EST
Created attachment 107434 [details]
verobose output of hald 0.4.1-snapshot
Comment 3 David Zeuthen 2005-01-13 14:56:59 EST
Please see if hal-0.4.5 fixes the bug; it's available in FC3 updates
as well as FC3 development.
Comment 4 Koenraad Heijlen 2005-01-15 18:44:31 EST
Tested: hal-0.4.5-1.FC3
with kernel: kernel-2.6.10-1.737_FC3 & kernel-2.6.9-1.724_FC3

No system freeze anymore, the CDROM and DVD Writer are both
recognized, filesystem sizes appear next to partitions. Works as
expected afaict.

Bug fixed, thanks for the follow up!
Comment 5 David Zeuthen 2005-01-17 15:26:08 EST
OK, so I'm closing this bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.