Bug 140811 - kernel header files do not match the running kernel
kernel header files do not match the running kernel
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ernie Petrides
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 21:57 EST by Donna Burych
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-29 20:43:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donna Burych 2004-11-24 21:57:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040803

Description of problem:
I changed the default kernel from 2.4.21-20.ELsmp to 2.4.21-20.EL and
rebooted my machine.  Several header files were changed in
/usr/src/linux-2.4.21-20.EL/include/config ...

ls -lart shows these with date/time of the reboot:


drwxr-xr-x   28 root     root         4096 Nov 23 21:03 ..
drwxr-xr-x   21 root     root         4096 Nov 23 21:03 x86
-rw-r--r--    1 root     root           19 Nov 23 21:03 smp.h
-rw-r--r--    1 root     root           26 Nov 23 21:03 highmem64g.h
-rw-r--r--    1 root     root           27 Nov 23 21:03 highmem4g.h
drwxr-xr-x    3 root     root         4096 Nov 23 21:03 cpu
drwxr-xr-x    2 root     root         4096 Nov 23 21:03 ewrk3
drwxr-xr-x  373 root     root        12288 Nov 23 21:03 .
-rw-r--r--    1 root     root           25 Nov 23 21:04 profiling.h
-rw-r--r--    1 root     root            0 Nov 23 21:04 oprofile.h
-rw-r--r--    1 root     root            0 Nov 23 21:04 MARKER

But when I changed back to the smp kernel and rebooted, these files
were not changed again.  The problem arose when I tried to rebuild
the vmware module vmmon.  It complains that the headers do not match
the running kernel.  This situation was reported in bugzilla report
101669 and was dismissed as a vmware bug.  But I can see the header
files were changed and never changed back when I went back to the smp
kernel.  I can compare them with a machine that I kept the
2.4.21-20.ELsmp kernel running on and they are different.  And this
machine builds the vmmon module without problems.

Version-Release number of selected component (if applicable):
kernel-source-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1.Change the default kernel to non-smp in /boot/grub/grub.conf.
2.Reboot and see that files in
/usr/src/linux-2.4.21-20.EL/include/config changed.
3.Change the default kernel back to smp and reboot and see that the
files did not change back.
    

Additional info:
Comment 1 Ernie Petrides 2004-11-30 00:37:29 EST
Donna, the include/config subdirectory is dynamically generated as
part of your build procedure (and also needs to be cleared out and
rebuilt when you want to rebuild for a different config).  What
procedure are you using?

(You're probably missing a "make mrproper" or a "make oldconfig" or
 a "make dep" to perform a fresh rebuild.)
Comment 2 Ernie Petrides 2004-12-08 19:22:18 EST
Donna, I could not reproduce this.  To the best of my knowledge, there is
no automatic update of files under /usr/src/linux-`uname -r`/include/config
at reboot.  I searched among all scripts in /etc, /etc/rc.d, /etc/init.d,
/sbin, and /usr/sbin.  (There is a script, /sbin/mkkerneldoth, that changes
/boot/kernel.h on each reboot, but it doesn't modify anything else.)

In particular, the output of "ls -lt include/config" (while residing in 
/usr/src/linux-2.4.21-27.EL) matched before and after the reboot from an
SMP kernel to the UP kernel (for 2.4.21-27.EL).

Note You need to log in before you can comment on or make changes to this bug.