Bug 140831 - selinux-policy-targeted update creates *.rpmnew files
selinux-policy-targeted update creates *.rpmnew files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 05:17 EST by Bernd Bartmann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 17:51:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2004-11-25 05:17:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The selinux-policy-targeted update 1.17.30-2.34 leaves .rpmnew files
lying around. This make the update useless as Joe user has no idea how
to handle .rpmnew files.

Here is the list of the *.rpmnew files I found after the update:

/etc/selinux/targeted/contexts/files/file_contexts.rpmnew
/etc/selinux/targeted/policy/policy.18.rpmnew

Also were is the announcement for the update?

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.34

How reproducible:
Always

Steps to Reproduce:
1. update to latest selinux-policy-targeted
2.
3.
    

Additional info:
Comment 1 Daniel Walsh 2004-11-30 11:55:17 EST
These files are being created because you installed
selinux-policy-targeted-sources and that install updated the policy.18
and file_contexts file.

We are working on newer versions and ways of fixing this problem.  You
can replace the policy.18 and file context file with the rpmnew file.

Dan
Comment 2 Bernd Bartmann 2004-11-30 14:27:19 EST
Ok, do I have to re-run some tool like after the renaming or a reboot?
How does the new policy come into effect?
Comment 3 Daniel Walsh 2004-11-30 14:29:07 EST
You can do a mv 

mv policy.18.rpmnew policy.18
load_policy policy.18

And you are done.

Note You need to log in before you can comment on or make changes to this bug.