Bug 140843 - redhat find-requires doesn't filter SUNWprivate whereas rpm does
redhat find-requires doesn't filter SUNWprivate whereas rpm does
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 09:26 EST by Paul Nasrat
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-17 15:52:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Following patch based pn /usr/lib/rpm/find-requires works as desired (364 bytes, patch)
2004-11-25 09:26 EST, Paul Nasrat
no flags Details | Diff

  None (edit)
Description Paul Nasrat 2004-11-25 09:26:22 EST
Description of problem:

rpm -ivh --test ../RPMS/java-1.4.2-sun-1.4.2.06-1jpp.i586.rpm
Password:
error: Failed dependencies:
        libjava.so(SUNWprivate_1.1) is needed by java-1.4.2-sun-1.4.2.06-1jpp.i586
        libjvm.so(SUNWprivate_1.1) is needed by java-1.4.2-sun-1.4.2.06-1jpp.i586
        libnet.so(SUNWprivate_1.1) is needed by java-1.4.2-sun-1.4.2.06-1jpp.i586
        libverify.so(SUNWprivate_1.1) is needed by java-1.4.2-sun-1.4.2.06-1jpp.i586


Version-Release number of selected component (if applicable):

redhat-rpm-config-8.0.32-1

How reproducible:

Always




Steps to Reproduce:
1.  Build java-1.4.2-sun from jpackage nosrc.rpm from jpackage
2.  rpm -ivh java-1.4.2-sun-{1,devel}*rpm
  
cf 

find /var/tmp/java-1.4.2-sun-1.4.2.06-1jpp-buildroot/ |
/usr/lib/rpm/redhat/find-requires

find /var/tmp/java-1.4.2-sun-1.4.2.06-1jpp-buildroot/ | /usr/lib/rpm/find-requires

Actual results:

Failure

Expected results:

Success

Additional info:
Comment 1 Paul Nasrat 2004-11-25 09:26:22 EST
Created attachment 107459 [details]
Following patch based pn /usr/lib/rpm/find-requires works as desired
Comment 2 Elliot Lee 2004-12-01 17:46:39 EST
find-requires/find-provides are very deprecated - rpm uses its own
internal mechanism for this, and while overriding it is possible, it
causes badness like this. Not sure if there is any action to take...?
Comment 3 Paul Nasrat 2004-12-02 13:56:30 EST
There are cases where disabling it is a valid and desirable choice,
and IIRC with the various JDK's we had some issues as we have very
little control over the contents of them.  In particular we get this
type of thing with the sun JDK as opposed to libname with the
find-provides/requires:

Without internal:
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjava.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjava.so(SUNWprivate_1.1)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjawt.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjcov.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjdwp.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjpeg.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjpeg.so(SUNWprivate_1.1)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libjsound.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libmlib_image.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libnet.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libnet.so(SUNWprivate_1.1)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libnio.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libnio.so(SUNWprivate_1.1)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/librmi.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libverify.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libverify.so(SUNWprivate_1.1)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libzip.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/libzip.so(SUNWprivate_1.1)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/native_threads/libhpi.so(GCC.INTERNAL)
/export/jdk142-update/ws/fcs/control/build/linux-i586/lib/i386/native_threads/libhpi.so(SUNWprivate_1.1)


True but the *rpm* find-requires doesn't cause the problem, the
redhat-rpm-config one does.  If you don't want to take a patch
backported from rpm itself can we just remove the redhat defined
find-requires/provides so that if internal disabled we always use the
rpm one so consistent behaviour is seen.
Comment 4 Elliot Lee 2005-04-12 16:43:00 EDT
I'm fine with removing find-requires/find-provides from redhat-rpm-config if
someone merges the changes into upstream rpm. Right now it looks like our
find-requires has a few changes that rpm may or may not.
Comment 5 Paul Nasrat 2005-04-13 05:43:05 EDT
Sure, file a new bug with specific changes, etc.
Comment 6 Ted Kaczmarek 2005-10-09 08:29:40 EDT
Any updates on this?
I hit this with FC4 and the java-1.4.2-sun-src-1.4.2.09, but not with the
java-1.5.0-sun-src-1.5.0.05.

Note You need to log in before you can comment on or make changes to this bug.