Bug 140851 - Sound Problems with Certain Intel Chips
Sound Problems with Certain Intel Chips
Status: CLOSED DUPLICATE of bug 147283
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
http://www.zd7000forums.com/viewtopic...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 11:04 EST by Johnny Proton
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my modprobe.conf file (409 bytes, text/plain)
2005-04-02 15:12 EST, Johnny Proton
no flags Details
my hwconf file (5.91 KB, text/plain)
2005-04-02 15:14 EST, Johnny Proton
no flags Details
Output of "lsmod" when sound is working (2.29 KB, text/plain)
2005-06-15 09:41 EDT, Johnny Proton
no flags Details
Output of "aplay -l" when sound is working (335 bytes, text/plain)
2005-06-15 09:42 EDT, Johnny Proton
no flags Details
Output of "lsmod" when sound not working (FC4) (4.80 KB, text/plain)
2005-06-15 10:11 EDT, Johnny Proton
no flags Details
Output of "aplay -l" when sound not working (FC4) (287 bytes, text/plain)
2005-06-15 10:12 EDT, Johnny Proton
no flags Details

  None (edit)
Description Johnny Proton 2004-11-25 11:04:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Epiphany/1.4.4

Description of problem:
Take a look at the URL provided.  My HP ZD7000 wouldn't play sound,
and it was due to the snd-intel8x0m device not being added to the
hotplug blacklist.  Apparently FC3 thought my soundcard was a USB device.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
This solution on the website the problem perfectly.  I thought this
may also fix bug #135979 but since he mentioned getting some sound to
work, I'm not sure.  Mine wouldn't play any sound at all.

Additional info:
Comment 1 Johnny Proton 2004-11-25 11:05:59 EST
This is the URL.  The "helper" didn't transfer it into the actual bug
report:

http://www.zd7000forums.com/viewtopic.php?t=3646
Comment 2 Bastien Nocera 2005-04-02 12:13:06 EST
Could you please attach your /etc/modprobe.conf as well as your
/etc/sysconfig/hwconf files?
Comment 3 Johnny Proton 2005-04-02 15:12:47 EST
Created attachment 112628 [details]
my modprobe.conf file
Comment 4 Johnny Proton 2005-04-02 15:14:28 EST
Created attachment 112629 [details]
my hwconf file
Comment 5 Martin Stransky 2005-06-01 08:41:52 EDT
Can you attach output of lsmod and 'aplay -l' when the sound works and when it
doesn't?
Comment 6 Johnny Proton 2005-06-15 09:41:15 EDT
Created attachment 115476 [details]
Output of "lsmod" when sound is working
Comment 7 Johnny Proton 2005-06-15 09:42:56 EDT
Created attachment 115477 [details]
Output of "aplay -l" when sound is working
Comment 8 Johnny Proton 2005-06-15 09:47:35 EDT
The previous 2 attachments are from my working FC3 machine.  

My other system (same laptop vendor, same sound card, same problem) now has FC4
on it.  And it seems that it may be broken worse on FC4 than it was before. 
During the installation process, clicking the "test sound" button during the
soundcard autodetection part actually froze the install completely.  Twice. 

I don't understand how this could happpen!  This is the number 1 Linux distro on
HP laptops, and it seems someone at Redhat would have one of these laptops to
test on.  I'm going to output the output from those commands on FC4 in the next
2 attachments.
Comment 9 Johnny Proton 2005-06-15 10:11:36 EDT
Created attachment 115479 [details]
Output of "lsmod" when sound not working (FC4)
Comment 10 Johnny Proton 2005-06-15 10:12:50 EDT
Created attachment 115480 [details]
Output of "aplay -l" when sound not working (FC4)
Comment 11 Johnny Proton 2005-06-15 10:24:54 EDT
Additionally, wanted to let you know that the same fix applied to FC4.  Just had
to blacklist the "snd-intel8x0m" in /etc/hotplug/blacklist and it worked fine.

Someone needs to look into this quickly though.  I'd say a replicated freeze
during installation is a high-priority bug!  Good luck.
Comment 12 Martin Stransky 2005-06-27 10:54:05 EDT

*** This bug has been marked as a duplicate of 147283 ***
Comment 13 Red Hat Bugzilla 2006-02-21 14:07:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.