Bug 140866 - System freezes when closing X session
System freezes when closing X session
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-25 16:33 EST by Pierre Juhen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 18:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pierre Juhen 2004-11-25 16:33:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.3)
Gecko/20041020

Description of problem:
When I close an X (KDE) session, the system freezes between the
X restart and the kdm start.

Screen i black, with a clock symbol.

Keyboard LEDS are blinking.

/var/log/messages shows 


Nov 24 23:25:08 pierre gdm(pam_unix)[3926]: session closed for user root
Nov 24 23:25:08 pierre kernel: NVRM: not using NVAGP, AGPGART is loaded!!
Nov 24 23:25:09 pierre kernel: Unable to handle kernel paging request
at virtual address dce56000
Nov 24 23:25:09 pierre kernel:  printing eip:
Nov 24 23:25:09 pierre kernel: c01552a6
Nov 24 23:25:09 pierre kernel: *pde = 1cc001e3
Nov 24 23:25:09 pierre kernel: *pte = 00000000
Nov 24 23:25:09 pierre kernel: Oops: 0002 [#1]
Nov 24 23:25:09 pierre kernel: PREEMPT
Nov 24 23:25:09 pierre kernel: Modules linked in: snd_usb_audio(U)
snd_usb_lib(U) snd_pcm_oss(U) snd_emu10k1(U) snd_mixer_oss(U)
snd_rawmidi(U) snd_pcm(U) s
nd_timer(U) snd_seq_device(U) snd_ac97_codec(U) snd_page_alloc(U)
snd_util_mem(U) snd_hwdep(U) snd(U) soundcore(U) ppp_deflate(U)
zlib_deflate(U) n_hdlc(U)
pppoatm(U) ppp_generic(U) slhc(U) lp(U) i2c_dev(U) i2c_core(U)
ipt_TCPMSS(U) iptable_mangle(U) ipt_MASQUERADE(U) iptable_nat(U)
ipt_LOG(U) ipt_limit(U) ipt_
state(U) ip_conntrack(U) iptable_filter(U) ip_tables(U) nvidia(U)
nls_cp437(U) vfat(U) fat(U) ntfs(U) speedtch(U) usb_atm(U) atm(U)
joydev(U) wacom(U) butto
n(U) battery(U) ac(U) ohci1394(U) ieee1394(U) uhci_hcd(U) ehci_hcd(U)
tg3(U) dm_snapshot(U) dm_zero(U) dm_mirror(U) ext3(U) jbd(U) dm_mod(U)
aic7xxx(U) sd_m
od(U) scsi_mod(U)
Nov 24 23:25:09 pierre kernel: CPU:    0
Nov 24 23:25:09 pierre kernel: EIP:    0060:[<c01552a6>]    Tainted: P
  VLI
Nov 24 23:25:09 pierre kernel: EFLAGS: 00213287   (2.6.9-1.681custom)
Nov 24 23:25:09 pierre kernel: EIP is at do_no_page+0x189/0x4cb
Nov 24 23:25:09 pierre kernel: eax: c1000000   ebx: c13f1ce0   ecx:
00000400   edx: 00000000
Nov 24 23:25:09 pierre kernel: esi: df8e7000   edi: dce56000   ebp:
d3abf100   esp: d28c2d4c
Nov 24 23:25:09 pierre kernel: ds: 007b   es: 007b   ss: 0068
Nov 24 23:25:09 pierre kernel: Process xkbcomp (pid: 4700,
threadinfo=d28c2000 task=dd784030)
Nov 24 23:25:09 pierre kernel: Stack: c139cac0 00000000 df93c7ec
008ad43c c810c2c4 00000001 d3abf100 008ad43c
Nov 24 23:25:09 pierre kernel:        d2d36008 c810c2c4 c01557dc
00000001 dc0152b4 d2d36008 d3abf100 d3abf130
Nov 24 23:25:09 pierre kernel:        c810c2c4 dd784030 c0117713
00000001 00000001 008ad43c d28c2e60 c03063b2
Nov 24 23:25:09 pierre kernel: Call Trace:
Nov 24 23:25:09 pierre kernel:  [<c01557dc>] handle_mm_fault+0xd9/0x249
Nov 24 23:25:09 pierre kernel:  [<c0117713>] do_page_fault+0x1b8/0x514
Nov 24 23:25:09 pierre kernel:  [<c01531f9>] unmap_page_range+0x3c/0x5f
Nov 24 23:25:09 pierre kernel:  [<c014b2e6>] prio_tree_insert+0xe6/0x15c
Nov 24 23:25:09 pierre kernel:  [<c014b763>]
vma_prio_tree_insert+0x17/0x2a
Nov 24 23:25:09 pierre kernel:  [<c0156a58>] vma_link+0x181/0x270
Nov 24 23:25:09 pierre kernel:  [<c01578bd>] do_mmap_pgoff+0x5b9/0x61b
Nov 24 23:25:09 pierre kernel:  [<c011755b>] do_page_fault+0x0/0x514
Nov 24 23:25:09 pierre kernel:  [<c02fa143>] error_code+0x2f/0x38
Nov 24 23:25:09 pierre kernel:  [<c01e3793>] direct_clear_user+0x4c/0x5a
Nov 24 23:25:09 pierre kernel:  [<c019c043>] load_elf_interp+0x2a0/0x2f2
Nov 24 23:25:09 pierre kernel:  [<c019ca71>] load_elf_binary+0x8cf/0xbf7
Nov 24 23:25:09 pierre kernel:  [<c0173756>] copy_strings+0x1d5/0x228
Nov 24 23:25:09 pierre kernel:  [<c017561e>]
search_binary_handler+0xc3/0x26c
Nov 24 23:25:09 pierre kernel:  [<c019c1a2>] load_elf_binary+0x0/0xbf7
Nov 24 23:25:09 pierre kernel:  [<c017592f>] do_execve+0x168/0x1f6
Nov 24 23:25:09 pierre kernel:  [<c01049fd>] sys_execve+0x2a/0x6f
Nov 24 23:25:09 pierre kernel:  [<c02f9f3f>] syscall_call+0x7/0xb
Nov 24 23:25:09 pierre kernel: Code: a1 10 9c 41 c0 89 de 8b 3c 24 29
c6 29 c7 b9 00 04 00 00 c1 fe 05 c1 ff 05 c1 e6 0c c1 e7 0c 81 ee 00
00 00 40 81 ef 00
 00 00 40 <f3> a5 8b 03 f6 c4 08 75 20 8b 43 04 40 75 08 0f 0b 40 01 e7 6d
Nov 24 23:25:09 pierre gconfd (root-4243): R�ception du signal 15,
arr�t correct
Nov 24 23:25:09 pierre gconfd (root-4243): Sortie


Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.1

How reproducible:
Sometimes

Steps to Reproduce:
1. Happened twice in the last days
2.
3.
    

Actual Results:  System freezes.

Keyboard and mouse lost.

Needs a reset.

Expected Results:  KDM screen to log in or shutdown the system

Additional info:
Comment 1 Sitsofe Wheeler 2004-11-28 15:48:12 EST
Hmm I notice binary nvidia drivers:
Nov 24 23:25:08 pierre kernel: NVRM: not using NVAGP, AGPGART is loaded!!

Looks like a dup of bug 73733
Comment 2 Mike A. Harris 2005-02-11 18:18:18 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "NOTABUG" (unsupported).

Note You need to log in before you can comment on or make changes to this bug.