Bug 140905 - kaddressbook crashes linux
kaddressbook crashes linux
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 04:49 EST by Alain D D Williams
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X config file (2.73 KB, text/plain)
2004-11-27 05:01 EST, Alain D D Williams
no flags Details
/var/log/Xorg.0.log (30.69 KB, text/plain)
2005-04-18 08:44 EDT, Alain D D Williams
no flags Details
/var/log/messages (66.48 KB, text/plain)
2005-04-18 08:52 EDT, Alain D D Williams
no flags Details
xconfig file (2.73 KB, text/plain)
2005-04-18 08:54 EDT, Alain D D Williams
no flags Details

  None (edit)
Description Alain D D Williams 2004-11-26 04:49:32 EST
Description of problem:

Use of kaddressbook distribution list editor crashes linux. This is
complete, it cannot be pinged from elsewhere. This only happens when
it is run on the local display, ie a remote X session seems safe.

I have put this against kaddressbook since that is how I found the
problem, but it should really belong elsewhere - probably X
I have tried it under different window managers and it still crashes.

Version-Release number of selected component (if applicable):

Latest fully patched system as of today.
Using kaddressbook (against the same data) yesterday on fedora 2 I had
no problems.

How reproducible:

Every time.


Steps to Reproduce:
1.

Run kmail

2.

Settings -> Show Extension Bar -> Distribution List Editor

3.

I have several (10) distribution lists each with many addresses, total
about 900; so you may need to create a few lists & populate them. I
have not tried this with an empty address book.

4.

Just to the left of 'New List ...' there is a pull down list of the
distribution lists. To get the system to crash I just select one list,
then select another, ... repeat a few times.
  
Actual results:

System crashes. Can't ping it.


Expected results:

System not crash.


Additional info:
Comment 1 Alain D D Williams 2004-11-27 05:01:31 EST
Created attachment 107497 [details]
X config file

Since X is likely to be implicated somewhere, I attach the X config file.
Comment 2 Ngo Than 2004-11-27 07:02:58 EST
sorry, i cannot reproduce this problem here with your instructions.

it looks like a hardware problem here, in this case X problem. I
assign it to xorg-x11.
Comment 3 Mike A. Harris 2005-02-01 01:58:32 EST
Please update your system with all Fedora Core 3 updates that have
been released by Red Hat, and reboot the system into the latest
update kernel.

After you've updated your system and rebooted, please try to
reproduce the problem.  If the problem still occurs, please attach
your X server log file, config file, and /var/log/messages, as
individual uncompressed file attachments using the link below.

Additionally, please provide the output of "lsmod".

Thanks in advance.
Comment 4 Mike A. Harris 2005-02-01 01:59:37 EST
Setting status to "NEEDINFO", awaiting testing results and
information requested in comment #3
Comment 5 Mike A. Harris 2005-04-15 10:34:32 EDT
This bug has not been updated to provide us with the information
we've requested above.  If you have not already updated to the
latest Fedora Core xorg-x11 and kernel updates, please do so now and
if you still encounter the problem described above, please report the
issue to X.Org bugzilla at http://bugs.freedestop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NOTABUG" due to lack of information.

Comment 6 Alain D D Williams 2005-04-15 11:10:13 EDT
I received a note saying that you have abandoned it due to lack of info ... I
have not received the previous request emails ... I will provide you with what
you need over the w/end.
Comment 7 Alain D D Williams 2005-04-18 08:44:14 EDT
Created attachment 113321 [details]
/var/log/Xorg.0.log

as asked for -- the system was brought up to date this morning (last done a
week ago) - one side effect of that is that the external mouse buttons (this is
a laptop) no longer work, to click/select I need to use the on-chassis buttons.
The external mouse is a Thrust optical wheel mouse (AMI mouse 2505 optical).

The other files coming up as extra attachments
Comment 8 Alain D D Williams 2005-04-18 08:52:50 EDT
Created attachment 113322 [details]
/var/log/messages

/var/log/messages -- trimmed down to a couple of reboots.

I was playing with mouseconfig to try to get the external mouse to work (see
previous item in bugzilla).

By the way -- the latest fixes don't change this problem ... just loading kmail
makes the system crash with the kmail message 'initialising' in the bottom LH
of the kmail window.
Comment 9 Alain D D Williams 2005-04-18 08:54:22 EDT
Created attachment 113323 [details]
xconfig file

Xorg.conf file

Note You need to log in before you can comment on or make changes to this bug.