Bug 140923 - Crash on aacraid load
Summary: Crash on aacraid load
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Paradis
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 123572
TreeView+ depends on / blocked
 
Reported: 2004-11-26 14:19 UTC by Bastien Nocera
Modified: 2013-08-06 01:10 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-02 14:26:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bastien Nocera 2004-11-26 14:19:21 UTC
This is a duplicate of bug #131703 for RHEL 2.1:

-const char *aac_driverinfo(struct Scsi_Host *host_ptr)
+const char *aac_info(struct Scsi_Host *shost)
 {
-       struct aac_dev *dev = (struct aac_dev *)host_ptr->hostdata;
+       struct aac_dev *dev = (struct aac_dev *)shost->hostdata;
        return aac_drivers[dev->cardtype].name;
 }

Which is the same code that was in RHEL3, pre-fix of that particular bug.

Patch seems to be included in:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=131703#c12


Note You need to log in before you can comment on or make changes to this bug.