Bug 140950 - snd_seq does not get loaded automatically
snd_seq does not get loaded automatically
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 15:22 EST by Gérard Milmeister
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:14:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gérard Milmeister 2004-11-26 15:22:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
When I start aplaymidi -l I get:

ALSA lib seq_hw.c:446:(snd_seq_hw_open) open /dev/snd/seq failed: No
such file or directory
Cannot open sequencer - No such file or directory

I have to do 'modprobe snd-seq', after that I get with aplaymidi -l:

 Port    Client name                      Port name
 64:0    EMU10K1 MPU-401 (UART) - Rawmidi EMU10K1 MPU-401 (UART)
 65:0    Emu10k1 WaveTable                Emu10k1 Port 0
 65:1    Emu10k1 WaveTable                Emu10k1 Port 1
 65:2    Emu10k1 WaveTable                Emu10k1 Port 2
 65:3    Emu10k1 WaveTable                Emu10k1 Port 3

modprobe.conf looks like this:

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias snd-card-0 snd-emu10k1
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
options snd-emu10k1 extin="0x3fc3" extout="0x1fc3"
remove snd-emu10k1 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
alias snd-card-1 snd-intel8x0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0


Version-Release number of selected component (if applicable):
udev-039-10.FC3.2

How reproducible:
Always

Steps to Reproduce:
 

Additional info:
Comment 1 Harald Hoyer 2004-11-29 05:44:51 EST
reassigning to kudzu to load snd-seq for soundcards
Comment 2 Bill Nottingham 2005-09-28 17:14:56 EDT
This should be fixed as of FC4. 

Note You need to log in before you can comment on or make changes to this bug.