Bug 1409637 - 0x0000007B BSOD after converting Windows 2008 R2 using p2v
Summary: 0x0000007B BSOD after converting Windows 2008 R2 using p2v
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs
Version: 7.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Pino Toscano
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 16:33 UTC by nijin ashok
Modified: 2020-02-14 18:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-16 13:37:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description nijin ashok 2017-01-02 16:33:05 UTC
Description of problem:

After converting Windows 2008 R2 physical machine, VM fails to start with error code: 0x0000007B. The booting was not working even with ide disk. The registry value for intelide was 3. But it was giving same error when this was changed to 0. The VM was able to boot when the following registry values was changed to 0.

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\pciide
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\msahci
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\iaStorV
HKEY_LOCAL_MACHINE\System\ControlSet001\Services\atapi

Not sure which one worked. However changing the disk to virtio is still giving the same BSOD error even after installing all the drivers within the guest.

Version-Release number of selected component (if applicable):

libguestfs-1.32.7-3.el7.x86_64


How reproducible:

Unknown

Steps to Reproduce:

1. Convert a physical Windows 2008 R2 using virt-p2v

2. VM fails to boot with BSOD

Actual results:

VM was not able to boot with BSOD error 0x0000007B

Expected results:

VM should be able to boot without manual intervention 

Additional info:

Comment 3 Richard W.M. Jones 2017-01-02 22:43:14 UTC
On a further look at the output, I've spotted a warning:

  virt-v2v: warning: there are no virtio drivers available for this version 
  of Windows (6.1 x86_64 Server).  virt-v2v looks for drivers in 
  /usr/share/virtio-win

  The guest will be configured to use slower emulated devices.

Please install the virtio-win package on the conversion server
and try the whole conversion again.

Comment 10 nijin ashok 2017-01-11 16:42:03 UTC
Issue was not reproducible when the virtio drivers was installed in the conversion server. The same physical machine was imported without any issue with the virtio drivers.

Comment 11 Richard W.M. Jones 2017-02-16 13:37:10 UTC
Closing per comment 10.  If you try this again, please make sure
the customer has the virtio-win drivers.


Note You need to log in before you can comment on or make changes to this bug.