Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1409693 - 'rhui haproxy reinstall' says there is no registered haproxy when there is one, and takes cds hostname to reinstall
Summary: 'rhui haproxy reinstall' says there is no registered haproxy when there is on...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Tools
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 3.0.7
: 3.0.x
Assignee: RHUI Bug List
QA Contact: Vratislav Hutsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 02:53 UTC by Irina Gulina
Modified: 2019-01-23 18:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-23 18:05:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0149 0 None None None 2019-01-23 18:05:17 UTC

Description Irina Gulina 2017-01-03 02:53:25 UTC
Description of problem:
1. 'rhui haproxy reinstall' says there is no registered isntances with the given hostname, but there is one
2. if to feed 'rhui haproxy reinstall' with cds hostname it will be reinstalled

Version-Release number of selected component (if applicable):
iso 20161220

How reproducible:
always

Steps to Reproduce:
1. rhui haproxy list to insure there is one
2. rhui haproxy reinstall hostname
3. msg: There are no registered instances with that hostname.


Actual results:
>> [root@rhua ~]# rhui haproxy list

-= RHUI HAProxy Load-balancers =-

  Hostname:             hap01.example.com
  SSH Username:         ec2-user
  SSH Private Key:      /root/.ssh/id_rsa_rhua


------------------------------------------------------------------------------
>> [root@rhua ~]# rhui haproxy reinstall hap01.example.com --help
usage: rhui haproxy reinstall [-h] hostname

positional arguments:
  hostname    The hostname of the instance to reinstall on; this instance must
              be registered already.

optional arguments:
  -h, --help  show this help message and exit

>>[root@rhua ~]# rhui haproxy reinstall hap01.example.com
There are no registered instances with that hostname.

>> rhui haproxy reinstall cds01.example.com

Checking that the RHUA services are reachable from the instance...
[ec2-user@cds01.example.com] sudo: yum install -d 0 -e 0 -y nc
[ec2-user@cds01.example.com] sudo: nc rhua.example.com 8140 < /dev/null
Done.


Installing Puppet on the HAProxy Load-balancer...
[ec2-user@cds01.example.com] sudo: yum install -y puppet
[ec2-user@cds01.example.com] sudo: puppet config set server rhua.example.com
Done.
[ec2-user@cds01.example.com] sudo: mkdir -p /etc/facter/facts.d
[ec2-user@cds01.example.com] put: /etc/puppet/rhui-secrets/rhui-custom-facts.json -> /etc/facter/facts.d/rhui-custom-facts.json

Setting up certificates...
[ec2-user@cds01.example.com] run: echo $HOME
[ec2-user@cds01.example.com] sudo: puppet config print certname
[ec2-user@cds01.example.com] sudo: rm -rf /var/lib/puppet/ssl
[ec2-user@cds01.example.com] sudo: mkdir -p /var/lib/puppet/ssl/{certs,private_keys}
[localhost] local: puppet cert clean cds01.example.com
[ec2-user@cds01.example.com] put: /var/lib/puppet/ssl/certs/ca.pem -> /home/ec2-user/ca.pem
[ec2-user@cds01.example.com] sudo: mv /home/ec2-user/ca.pem /var/lib/puppet/ssl/certs/ca.pem
[ec2-user@cds01.example.com] sudo: puppet agent --onetime --detailed-exitcodes --no-daemonize --no-usecacheonfailure
[ec2-user@cds01.example.com] run: echo $HOME
[ec2-user@cds01.example.com] sudo: cp -r /var/lib/puppet/ssl/certificate_requests/cds01.example.com.pem /home/ec2-user/cds01.example.com.pem
[ec2-user@cds01.example.com] sudo: chown -R $USER /home/ec2-user/cds01.example.com.pem
[ec2-user@cds01.example.com] download: /var/lib/puppet/ssl/ca/requests/cds01.example.com.pem <- /home/ec2-user/cds01.example.com.pem

Warning: Local file /var/lib/puppet/ssl/ca/requests/cds01.example.com.pem already exists and is being overwritten.

[ec2-user@cds01.example.com] sudo: rm -rf /home/ec2-user/cds01.example.com.pem
[localhost] local: puppet cert sign cds01.example.com
Done.

Installing and configuring the HAProxy Load-balancer...
[ec2-user@cds01.example.com] sudo: puppet agent --onetime --detailed-exitcodes --no-daemonize --no-usecacheonfailure
Done.

Ensuring that Apache and Crane are available...
[localhost] local: yum install -y nc
[localhost] local: nc cds01.example.com 443 < /dev/null
[localhost] local: nc cds01.example.com 5000 < /dev/null
Done.

Comment 3 Craig Donnelly 2017-08-03 23:46:57 UTC
There should be a check in this argument that verifies that the target is an haproxy. Should not allow reinstall of haproxy against an already defined CDS which is not meant to be the haproxy.

Comment 7 errata-xmlrpc 2019-01-23 18:05:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0149


Note You need to log in before you can comment on or make changes to this bug.