Bug 1409712 - SSA failed for OSP instance: Unable to mount filesystem. Reason:[No root filesystem found.]
Summary: SSA failed for OSP instance: Unable to mount filesystem. Reason:[No root fil...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Jerry Keselman
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-03 05:31 UTC by Chen
Modified: 2019-08-06 20:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-12 22:37:30 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
SSA logs with grepped jobID (1.04 MB, text/plain)
2017-01-03 05:31 UTC, Chen
no flags Details

Description Chen 2017-01-03 05:31:21 UTC
Created attachment 1236765 [details]
SSA logs with grepped jobID

Description of problem:

SSA failed for OSP instance.

Seems that every directory is appended with a strange suffix.

[----] D, [2017-01-03T00:21:27.516962 #3064:61b994] DEBUG -- : LinuxMountProbe << FALSE because root directories (["bin", "dev", "etc", "lib", "proc", "sbin", "usr"]) missing in: [".        ", "..", "bin\a", "boot\x02", "dev\x02", "etc\x02", "home\x02", "lib\a", "lib64\a", "media\x02", "mnt\x02", "opt\x02", "proc\x02", "root\x02", "run\x02", "sbin\a", "srv\x02", "sys\x0        2", "tmp\x02", "usr\x02", "var\x02"]
[----] E, [2017-01-03T00:21:27.517143 #3064:61b994] ERROR -- : Unable to mount filesystem.  Reason:[No root filesystem found.] for VM [7034a26c-2477-443d-ac19-4328ea123984]



Version-Release number of selected component (if applicable):

CFME-5.6.3.3-20161128141841_49d925b
rhel-guest-image-7.3-35.x86_64.qcow2
OSP 8.0

How reproducible:

100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Rich Oliveri 2017-01-05 15:17:25 UTC
Jerry,

The description of the problem sounds familiar. Does this sound like something you've fixed in the past?

Comment 4 Jerry Keselman 2017-01-05 15:23:09 UTC
This is the XFS bug that I fixed and then Hui also came across - and then we back ported (to Darga, I believe).

Comment 5 Jerry Keselman 2017-01-05 15:29:17 UTC
https://github.com/ManageIQ/manageiq/pull/12003.  It has been back-ported to both Darga and Euwe.

Comment 6 Chen 2017-01-06 06:34:39 UTC
Hi Jerry and Rich,

Thank you very much for your reply.

As CFME 4.2 was released yesterday I will try the new version. 

Best Regards,
Chen


Note You need to log in before you can comment on or make changes to this bug.