This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 140993 - useless files included, incomplete h2ph, wrong files location, duplicate files...
useless files included, incomplete h2ph, wrong files location, duplicate file...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 11:00 EST by Marius Feraru
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 06:47:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
spec diff (9.81 KB, patch)
2004-11-27 11:00 EST, Marius Feraru
no flags Details | Diff
perl-PH (extra source including "header" files to be h2ph-ed) (483 bytes, text/plain)
2004-11-27 11:01 EST, Marius Feraru
no flags Details
spec diff (11.41 KB, patch)
2004-11-29 05:28 EST, Marius Feraru
no flags Details | Diff
spec diff (to perl-5.8.5-10) (13.82 KB, patch)
2004-11-29 11:50 EST, Marius Feraru
no flags Details | Diff

  None (edit)
Description Marius Feraru 2004-11-27 11:00:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041114 Firefox/1.0

Description of problem:
here is the changelog entry from my modified spec:
- added build conditionals: threading, largefiles, test, compat, suid
- cleaned up some "perlver" macro usage
- switched to using the "bz2" source
- made Source to point to the URL on CPAN
- updated Requirements
- tweaked Configure flags: disabled some useless items etc
- switched to using "test-notty" for make-test phase
:: heavy lift-ups in %install stage:
- more useless files are dropped
- eliminated files duplication (replacing them with symlinks)
- fixed POSIX installation
- added more comments :))
- more complete h2ph headers building (using a separate source file
with filenames)
- marked POD files as documentation
- marked libnet as configuration
(more to come in a future sync of my perl packages with Fedora's)


Version-Release number of selected component (if applicable):
5.8.5-10

How reproducible:
Always

Steps to Reproduce:
rpm -ql perl
Comment 1 Marius Feraru 2004-11-27 11:00:59 EST
Created attachment 107498 [details]
spec diff
Comment 2 Marius Feraru 2004-11-27 11:01:44 EST
Created attachment 107499 [details]
perl-PH (extra source including "header" files to be h2ph-ed)
Comment 3 Marius Feraru 2004-11-29 05:28:12 EST
Created attachment 107530 [details]
spec diff

a new spec, including more fixes/tweaks. the updated changelog entry is:

- added build conditionals: threading, largefiles, test, compat, suid
- cleaned up some "perlver" macro usage
- switched to the "bz2" source
- made Source to point to a URL (on CPAN)
- updated Requirements
- tweaked Configure flags: disabled some useless items etc
- switched to using "test-notty" for make-test phase
- heavy lift-ups in %%install stage...
- more useless files are dropped
- eliminated files duplication (replacing them with symlinks)
- fixed POSIX installation
- added more comments in the spec :))
- more complete h2ph headers building
- marked POD files as documentation
- marked libnet as configuration
- enforcing "..arch../auto" dirs creation/ownership
Comment 4 Marius Feraru 2004-11-29 11:50:56 EST
Created attachment 107554 [details]
spec diff (to perl-5.8.5-10)

- perl version 5.8.6
- dropped external __perl_requires file (integrated it into the spec)
- dropped MANIFEST.suidperl and system-owned-directories (integrated in spec)
- dropped clean-manifest.pl (no longer necessary)
- more cruft cleaned up
Comment 5 Warren Togami 2005-05-17 22:51:32 EDT
Perl team, please check if any of this is still relevant.
Comment 6 Warren Togami 2005-09-11 06:47:19 EDT
Closing due to lack of response from original submitter, and things in the perl
package have changed substantially since then.

Note You need to log in before you can comment on or make changes to this bug.