Bug 141002 - Cannot install FC3 (installer hangs) on Tyan AMD-760 motherboard
Cannot install FC3 (installer hangs) on Tyan AMD-760 motherboard
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 16:11 EST by Philippe Rigault
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:09:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Rigault 2004-11-27 16:11:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
This happens both with Fedora Core2 and Fedora Core 3 CDs.
Machine has been happily running Fedora Core 1 for just over a year (using 2.4 kernels, currently 2.4.27).

Tyan TigerMP S2460 motherboard
(AMD-760 MP chipset, IDE controller)
BIOS v1.05
Dual AthlonMP 1800+
1GB RAM





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot machine with Fedora Core install CD -> Fedora start menu shows up
2. Press 'Enter' to boot Linux
3.
    

Actual Results:  loads vmlinux
loads initrd.img...
Hangs immediately after that, all I get is a blinking cursor.

This has prevented me from upgrading from FC1.

Expected Results:  Boots normally to get to the install process

Additional info:

Tried the following options, without success:
  acpi=off
  noprobe
Comment 1 Dave Jones 2004-11-27 16:17:03 EST
can you try initcall_debug option on FC3 ?
(make sure 'quiet' isnt also on the command line)
Comment 2 Philippe Rigault 2004-11-27 16:45:55 EST
Entered: linux initcall_debug 
 
Same effect:  
 
Loading vmlinux 
Loading initrd.img................................................. 
hangs with blinking cursor just after that 
 
Comment 3 Philippe Rigault 2004-11-27 20:02:21 EST
I tried to boot this box with the same 2.6 kernel as FC3 has on the CD. 
Same results: kernel hangs immediately. 
 
Here are the details, in case I am missing something: 
 
1. Downloaded kernel-2.6.9-1.667.src.rpm 
 
2. Build the sources this way: 
  rpm -ivh kernel-2.6.9-1.667.src.rpm 
  rpmbuild -bp kernel-2.6.spec to create patched sources 
  cp -a /usr/src/redhat/BUILD/kernel-2.6.9/linux-2.6.9 /usr/src/linux-2.6.9-FC3 
  set EXTRAVERSION = -FC3 in Makefile 
 
3. Configure kernel for the box and build 
  make xconfig (can send you .config upon request) 
  make modules_install, make install 
  cd /boot ; /sbin/mkinitrd /boot/initrd-2.6.9-FC3.img 2.6.9-FC3 
  update lilo (linuxFC3) 
  make sure /etc/modprobe.conf is there (generated from /etc/modules.conf) 
 
4. Reboot -> Hangs in 'Loading linuxFC3' 
 
FWIW, this FC1 box uses: 
binutils-2.15.90.0.1.1-2 
modutils-2.4.25-13 
mkinitrd-3.5.14-1 
 
Comment 4 Dave Jones 2005-07-15 14:58:52 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Dave Jones 2005-10-02 21:09:38 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.