Bug 141014 - when at login and boot screen font to small to read
when at login and boot screen font to small to read
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 23:56 EST by brian henson
Modified: 2013-03-05 22:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-22 02:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brian henson 2004-11-27 23:56:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
when the fedora core 3 is booted the graphical boot screens font is 
to small to read and when you get to the login screen you cant read 
the font but when you get in the desktop you can read it all.   

Version-Release number of selected component (if applicable):3


How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
    

Actual Results:  same result

Expected Results:  can read font

Additional info:
Comment 1 Daniel Veillard 2004-11-30 10:09:24 EST
I can't reproduce that and the bug report give no hint of 
what specifically lead to this:

what resolution are you using ? 
Is xfs started correctly without errors ?
Can you check that your packages are pristine with rpm -Va 
especially that there is no report related to xorg packages.

In the current state that bug cannot be processed by lack
of reproductability.

Daniel
Comment 2 brian henson 2004-12-02 16:07:37 EST
800 by 600 ATI card
default monitor 800 by 600
standard xpackages from fedora 3
packages are pristine
xfs is started with out error
if need any more info i can send you a sreeen shot
Comment 3 Terre Porter 2005-02-07 17:26:21 EST
Did anything come of this?

I too am having this problem. I've tried changing screen res, changin
the desktop theme and graphical login, nothing seems to change the
font size on the graphical login.

Standard fedora 3 install, updated with yum (yum from redhat servers)
1024x768 current rez at 70mhz (changin the refresh rate also had no
effect on the text size)

The only error so to speak is the graphical interface fails to load 1
out of 3 times, reboot and it loads fine with no problems except for
the very small font size. Haven't figured out what is causing it to
hang, yet.

Let me know if there was a fix for this or if you need more information.

Thanks
Terre
Comment 4 brian henson 2005-02-15 16:22:20 EST
No I am still waiting for a fix
Comment 5 Daniel Veillard 2005-02-15 16:40:10 EST
In the current state that bug cannot be processed by lack
of reproductability, this is still true.

Daniel
Comment 6 Terre Porter 2005-02-15 16:54:41 EST
Thanks for the responses, Brian , Daniel.

I've got a small update, though it might not be too helpful.

Forgive me for not being a Linux expert, most of my linux is for my
simple firewall, but it seems the problem is when the system attempts
to detect the monitor. I had the problem after another rebuild, the
system took a few minutes to load the x login screen and after it did
load the small fonts were back. 

The one thing that bugged me the most was that the problem didn't
occur when it was being build.

So I tried a different monitor, figuring the only difference was the
monitor. On the first boot the system took a minuete before loading
the x login, but when it did the fonts were the correct size.

I'm guessing that there is some display detection script that is doing
something , though I don’t have a clue if I’m correct or where it
would be located.

Brian, have you tried the machine on a different monitor. Since it
worked for mine, maybe it will work for yours.

Daniel, is there a detection script or something like what I described
that your know of?
Comment 7 brian henson 2005-02-19 17:08:48 EST
when i tryed a different monitor a Philips magnavox monitor it still 
did it but when i use a gateway monitor it works it must be a problem 
with the display drivers for the philips magnavox monitors
Comment 8 Rei Victor dela Cruz 2005-03-07 18:44:58 EST
When I upgraded from FC1 to FC3, this bug did not appear. The boot and
login screens were as they should be. However, when I did a clean
install of FC3, that is when the small unreadable fonts appeared. 

I'm just wondering if this is a problem with the monitor/display
driver, shouldn't the fonts after logging in behave similarly (small
and unreadable)? Why does it only affect the boot and login screens?
Do those screens have a different configuration file where the default
font sizes can be setup?
Comment 9 Bengt Johannesson 2005-03-20 05:21:00 EST
I think I have discovered what triggers the problem. It is the dpi of the X-server.

The problem was disappeared on my TV-output when I did the following change in
/etc/X11/xorg.conf, Section "Monitor":
#       DisplaySize  670 390 # May confuse rhgb boot font if that big
       DisplaySize 240 135 # Aspect 16:9
Comment 10 Matthias Clasen 2005-04-22 02:03:39 EDT
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.