Bug 141030 - /etc/vimrc.rpmnew always created when vim upgraded
/etc/vimrc.rpmnew always created when vim upgraded
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 10:49 EST by W. Michael Petullo
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-06 05:57:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2004-11-28 10:49:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.3)
Gecko/20041027 Epiphany/1.4.4

Description of problem:
I am following the Fedora Raw Hide tree.  Everytime I upgrade vim, the
package creates a /etc/vimrc.rpmnew.  The contents of /etc/vimrc and
/etc/vimrc.rpmnew are always the same.

Version-Release number of selected component (if applicable):
vim-common-6.3.033-1

How reproducible:
Always

Steps to Reproduce:
Upgrade to a newer vimrc package.  Notice that /etc/vimrc.rpmnew is
created.  Also notice that "diff /etc/vimrc /etc/vimrc.rpmnew" prints
nothing.  Why is /etc/vimrc.rpmnew created?

Additional info:
Comment 1 Karsten Hopp 2004-11-29 09:34:45 EST

*** This bug has been marked as a duplicate of 132371 ***
Comment 2 W. Michael Petullo 2005-02-14 12:51:43 EST
I just upgraded to 6.3.061-2 and got the "warning: /etc/vimrc created as
/etc/vimrc.rpmnew" message again.  /etc/vimrc and /etc/vimrc.rpmnew are
identical.  I could not reopen #132371 because I did not initially open that one.
Comment 3 W. Michael Petullo 2005-07-18 14:03:29 EDT
I just saw "warning: /etc/vimrc created as
/etc/vimrc.rpmnew" when upgrading to 6.3.080-1.  The contents of
/etc/vimrc.rpmnew and /etc/vimrc are identical.
Comment 4 Karsten Hopp 2005-09-06 05:57:22 EDT
That's due to a limitation in rpm. If you have the same config file in two
subpackages which don't require each other, you'll end up with a rpmnew file.
There's only one solution which I'd like to avoid: move the vimrc into its own
subpackage and require that by vim-minimal and vim-common.
Comment 5 Nils Philippsen 2005-10-28 08:41:52 EDT
It's arguable what's uglier, getting vimrc.rpmnew or having a "vim-vimrc"
("vim-config", ...) subpackage. I deem the latter the lesser of two evils,
especially in the light of that this is actually one the primary purposes of
subpackages (to avoid packaging common files into multiple packages). Maybe for
FC5 (pretty please :-)?

Note You need to log in before you can comment on or make changes to this bug.