Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410331 - Repository sync schedule doesn't take daylight saving into consideration
Summary: Repository sync schedule doesn't take daylight saving into consideration
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Sync Plans
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-05 07:31 UTC by Hao Chang Yu
Modified: 2021-06-10 11:47 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 17:58:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 2778 0 Normal CLOSED - NOTABUG Repository sync schedule moves based on timezone changes like daylight savings time. 2017-11-26 17:02:54 UTC
Red Hat Knowledge Base (Solution) 3467201 0 None None None 2018-06-02 09:28:40 UTC

Description Hao Chang Yu 2017-01-05 07:31:23 UTC
Description of problem:
User runs sync plan daily on '10.00 -07:00'(PDT). When user switches back from the daily saving to PST (-08:00), the Web UI still showing "10.00 PST" but the sync started 1 hour earlier (09:00 PST) than the showing time.

The sync task ran an hour earlier because the Pulp sync task was scheduled based on 10.00 PDT (or 17.00 UTC) time initially. Satellite only schedule the pulp task once when user set the start_date.

Version-Release number of selected component (if applicable):
6.2


Steps to Reproduce:
1. Go to Administer -> Users -> Admins
2. Set Timezone to ''Pacific Time (US & Canada)'
3. Create a sync plan and set the start date to 2016/07/13 10:00:00. This is the daylight saving time
4) Refresh the page

Actual results:
The Next sync date is showing 10.00 PST

Expected results:
The Next sync date should show 09.00 PST

Comment 13 pulp-infra@redhat.com 2017-06-15 13:02:15 UTC
The Pulp upstream bug status is at CLOSED - WONTFIX. Updating the external tracker on this bug.

Comment 14 pulp-infra@redhat.com 2017-06-15 13:02:19 UTC
The Pulp upstream bug priority is at Normal. Updating the external tracker on this bug.

Comment 19 pulp-infra@redhat.com 2017-11-26 17:02:55 UTC
The Pulp upstream bug status is at CLOSED - NOTABUG. Updating the external tracker on this bug.

Comment 26 jalviso 2018-08-23 06:29:20 UTC
Hi,

Do we have any news on this bugzilla?

Regards,

Josephine Alviso
GSS - APAC

Comment 27 Brad Buckingham 2018-08-23 11:55:56 UTC
No updates at this time.  The bugzilla is on the backlog and remains a candidate for a future release.

Comment 28 Bryan Kearney 2018-09-04 17:58:39 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.