Bug 141049 - Please build FC kernel with alps.patch applied from synaptics
Please build FC kernel with alps.patch applied from synaptics
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://web.telia.com/~u89404340/touch...
: FutureFeature
: 141061 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 14:48 EST by Alex Butcher
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-16 03:09:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Butcher 2004-11-28 14:48:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
ALPS Glidepoint trackpads are supported by the synaptics driver, but
need a patch applied to the kernel (I guess to stop the generic PS/2
driver from claiming the device). It'd be nice if this was in the
standard FC kernel, seeing as the synaptics userland stuff is now in FC.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1. Check kernel source for evidence of alps.patch being applied
    

Actual Results:  alps.patch wasn't applied to the standard FC kernel.

Expected Results:  alps.patch was applied to the standard FC kernel.

Additional info:
Comment 1 Dave Jones 2004-11-28 15:29:36 EST
why isnt this in the upstream kernel yet ?
Got pointer to the patch ?
Comment 2 Alex Butcher 2004-11-28 19:39:41 EST
I've no idea why this isn't in the upstream kernel - I've mailed
Vojtech seperately.

The patch is included in the tarball available from the URL for this
bugzilla.
Comment 3 Alex Butcher 2004-11-28 19:41:01 EST
*** Bug 141061 has been marked as a duplicate of this bug. ***
Comment 4 Alex Butcher 2004-11-29 04:40:06 EST
On Sun, Nov 28, 2004 at 08:02:46PM +0000, Alex Butcher wrote:        
          
> Hi Vojtech -                                                       
          
>                                                                    
          
> The synaptics userland driver for synaptics and ALPS touchpads needs
a        
patch                                                                
          
> applied to the kernel. It can be found as alps.patch in            
          
>
<http://web.telia.com/~u89404340/touchpad/files/synaptics-0.13.6.tar.bz2>
    
                                                                     
          
I know, and I'm currently working on fixing that patch so that it can
be        
included in the kernel.                                              
          
                                                                     
          
--                                                                   
          
Vojtech Pavlik                                                       
          
SuSE Labs, SuSE CR     
Comment 5 Dave Jones 2005-07-15 14:13:04 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Alex Butcher 2005-07-16 03:08:09 EDT
I think this patch, or something equivalent, is in 2.6.12-1.1372_FC3 now.

Note You need to log in before you can comment on or make changes to this bug.