Bug 141059 - sleeping function called from invalid context at include/asm/semaphore.h:107
sleeping function called from invalid context at include/asm/semaphore.h:107
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 19:18 EST by Parag Warudkar
Modified: 2015-01-04 17:13 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 16:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Warudkar 2004-11-28 19:18:30 EST
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
While capturing Video using Kino, I got the below error in dmesg. 
The device is a Sony TRV240 Handycam.  
 
Version-Release number of selected component (if applicable): 
2.6.9-1.681_FC3 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Attach the Handycam  
2. Capture video using Kino 
3. See the error in dmesg. 
     
 
Actual Results:  ieee1394: raw1394: /dev/raw1394 device initialized 
ieee1394: Current remote IRM is not 1394a-2000 compliant, 
resetting... 
ieee1394: Node added: ID:BUS[0-00:1023]  GUID[0800460102e81a7c] 
ieee1394: Node changed: 0-00:1023 -> 0-01:1023 
Debug: sleeping function called from invalid context at 
mm/slab.c:2063 
in_atomic():0[expected: 0], irqs_disabled():1 
 [<0211cbcb>] __might_sleep+0x7d/0x8a 
 [<0214bf9f>] __kmalloc+0x42/0x7d 
 [<32b9abf2>] alloc_dma_rcv_ctx+0x5f/0x3a3 [ohci1394] 
 [<32b980ad>] ohci_devctl+0x1dc/0x799 [ohci1394] 
 [<0215222e>] follow_page_pte+0xec/0xfd 
 [<32bec615>] hpsb_listen_channel+0x3f/0x46 [ieee1394] 
 [<32ddd2ac>] handle_iso_listen+0x11c/0x268 [raw1394] 
 [<32de0c47>] state_connected+0xf1/0x1c7 [raw1394] 
 [<32de0d9b>] raw1394_write+0x7e/0x92 [raw1394] 
 [<02165c82>] vfs_write+0xb6/0xe2 
 [<02165d4c>] sys_write+0x3c/0x62 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
Debug: sleeping function called from invalid context at 
include/asm/semaphore.h:107 
in_atomic():0[expected: 0], irqs_disabled():1 
 [<0211cbcb>] __might_sleep+0x7d/0x8a 
 [<02245afd>] dma_pool_destroy+0x1a/0x114 
 [<32b9ab6a>] free_dma_rcv_ctx+0x9f/0xc8 [ohci1394] 
 [<32b98649>] ohci_devctl+0x778/0x799 [ohci1394] 
 [<32bec657>] hpsb_unlisten_channel+0x3b/0x3e [ieee1394] 
 [<32ddd33b>] handle_iso_listen+0x1ab/0x268 [raw1394] 
 [<32de0c47>] state_connected+0xf1/0x1c7 [raw1394] 
 [<32de0d9b>] raw1394_write+0x7e/0x92 [raw1394] 
 [<02165c82>] vfs_write+0xb6/0xe2 
 [<02165d4c>] sys_write+0x3c/0x62 
application kino uses obsolete OSS audio interface 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
ohci1394: fw-host0: Waking dma ctx=0 ... processing is probably too 
slow 
Debug: sleeping function called from invalid context at 
include/asm/semaphore.h:107 
in_atomic():0[expected: 0], irqs_disabled():1 
 [<0211cbcb>] __might_sleep+0x7d/0x8a 
 [<02245afd>] dma_pool_destroy+0x1a/0x114 
 [<32b9ab6a>] free_dma_rcv_ctx+0x9f/0xc8 [ohci1394] 
 [<32b98649>] ohci_devctl+0x778/0x799 [ohci1394] 
 [<32bec657>] hpsb_unlisten_channel+0x3b/0x3e [ieee1394] 
 [<32ddd33b>] handle_iso_listen+0x1ab/0x268 [raw1394] 
 [<32de0c47>] state_connected+0xf1/0x1c7 [raw1394] 
 [<32de0d9b>] raw1394_write+0x7e/0x92 [raw1394] 
 [<02165c82>] vfs_write+0xb6/0xe2 
 [<02165d4c>] sys_write+0x3c/0x62 
 
 
Expected Results:  Should have captured without error. 
 
Additional info:
Comment 1 Dave Jones 2005-07-15 15:38:13 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 2 Parag Warudkar 2005-07-15 16:28:10 EDT
Fixed in 2.6.11

Note You need to log in before you can comment on or make changes to this bug.