Bug 141060 - Anaconda crashes with network_gui.py assertion failure
Anaconda crashes with network_gui.py assertion failure
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 19:21 EST by Michael
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 15:24:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log and syslog files (10.37 KB, application/octet-stream)
2004-12-11 00:24 EST, Michael
no flags Details

  None (edit)
Description Michael 2004-11-28 19:21:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I have successfully installed FC3 on two other systems. On one system
I have problems. It is an amd64 system. Note that I am trying to
install the 32 bit version of FC3. (because there is no Java plugin
yet for amd64). This should not be a problem. 

The system installs and runs fine with both FC2 and FC2_64. 

On this system the graphical installation process starts and gets
through all the user input. But after formatting the partitions
anaconda crashes with:

/usr/lib/anaconda/iw/network_gui.py: 265: GtkWarning: file Gtktable.c
line 515 (gtk_table_resize): assertion n_rows > 0 && n_rows < 65536
'failed devTable = Table(len(devopts), 2)


I tried installing FC3 using the text installer and it crashes hard
... seemingly at about the same place in the installation ... after
formatting the partitions. 

I was unable to get the diagnostics from the text install crash. If
you tell me how to collect the data then I will reinstall. 

I suspect that this may be videocard related. After reinstalling FC2
(32 bit) my /etc/X11/xorg.conf has:

  BoardName "NVIDEA GeForce 4 MX (generic)"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to install FC3 on my system
2. start the process ... watch drives get formatted
3. see it anaconda crash with assertion failure
    

Additional info:

I will be glad to try to reinstall if you can tell me how to collect
data to determine what is failing. 

I had no troubles with installation of FC2 ... FC3 dies.
Comment 1 Jeremy Katz 2004-11-29 09:24:08 EST
Can you verify your install media according to the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html?
Comment 2 Vic Serbe 2004-11-30 17:04:02 EST
This seems to only happen if you don't leave it set as DHCP in the
network configuration during installation, and try to configure
specific IP/GW/DNS and hostname settings.
Comment 3 Michael 2004-11-30 18:10:28 EST
I did a media check before the installation. 
I have installed two other FC3 systems from the same media. 

Per Vic's comment, I also turned off DHCP and manually configured the
IP/GW/DNS settings. And I did this in the text installer as well
(which crashed very hard)

But I am quite sure that I set a fixed IP address at install time on
one of my other FC3 system as well ... and that one had no problems. 
Comment 4 Jeremy Katz 2004-11-30 22:48:56 EST
Actually, that's just a warning from pygtk -- it doesn't actually lead
to the crash you're seeing.  Can you hit ctrl-s when it crashes and
switch to tty2 to grab both /tmp/anaconda.log and /tmp/syslog?
Comment 5 Michael 2004-11-30 23:58:13 EST
You said:

"Can you hit ctrl-s when it crashes and
switch to tty2 to grab both /tmp/anaconda.log and /tmp/syslog?"

Q: Please confirm that you are referring the text mode installer for
FC3. You would like me to attempt to reinstall with the text mode
installer, hit ctrl-s to halt the screen output, and hit alt-f2 to
swith to tty2

Q: How do I 'grab' these files? What device can I write them to?
Comment 6 Jeremy Katz 2004-12-01 14:19:09 EST
Yes, that's fine for text-mode.  You can grab the files either by
copying them to a floppy or by copying them off via the network.
Comment 7 Michael 2004-12-01 17:23:05 EST
I don't have a floppy. 

I will be in the middle of an installation that just crapped out
because I put in a fixed IP address ... do you think that the network
is going to be up? 

Will the USB drivers be running so that I can copy it to a USB device? 
Comment 8 Michael 2004-12-11 00:17:47 EST
I installed a floppy in order to grab the logs. 

I ran a bunch of other tests:
 - tried two other video cards ... still died
 - tried different monitor ... still died
   (I thought that perhaps 'unknown/unrecognized monitor' was an issue)
 - tried with DHCP instead of fixed IP ... still died

Comment 9 Michael 2004-12-11 00:24:27 EST
Created attachment 108384 [details]
anaconda.log and syslog files

anaconda.log and syslog files for failed installation of FC3
Comment 10 Michael 2004-12-18 22:03:27 EST
I am ready to pick up this thread and try to help get this issue
resolved. 
Comment 11 Kirill Trofimov 2005-02-10 07:42:43 EST
After crash on my box tty4 says:

<3> Out of memory: process 360 killed (anaconda)

I have 128M of RAM and no swap partition. Trying to add more memory and see 
what will happen.
Comment 12 Kirill Trofimov 2005-02-10 07:58:47 EST
512M RAM - it works just fine!
Comment 13 Michael 2005-02-10 09:27:58 EST
Glad that additional memory seemed to solve your problem. 
This bug report was originally filed on a system that has 1Gb RAM. 
Issue is still not resolved and I am still willing to work on it. 
Comment 14 Michael 2005-02-12 15:24:18 EST
I recommend that this bug be closed. 

My previous install was into a new logical volume of a lvm1 volume group. 

Doing a completely clean installation on to a wiped hard drive works OK. 

Note You need to log in before you can comment on or make changes to this bug.