Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1410692 - guest recipe XML has guest-related attributes in the wrong place
Summary: guest recipe XML has guest-related attributes in the wrong place
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Retired
Component: general
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: 24.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-06 05:48 UTC by Dan Callaghan
Modified: 2017-02-21 18:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-21 18:50:01 UTC


Attachments (Terms of Use)

Description Dan Callaghan 2017-01-06 05:48:19 UTC
Version-Release number of selected component (if applicable):
unreleased develop

How reproducible:
easily

Steps to Reproduce:
1. Fetch http://$BEAKER/recipes/$GUESTRECIPEID.xml

Actual results:
The guestname, guestargs, mac_address, location, and *_location attributes for the guest appear on the top-level <job> element.

Expected results:
The attributes should be on the <guestrecipe> element to which they apply.

Additional info:
Regression in 57ccf02cf63abb6a7c516ab0fb58cdeaaefbef7c which went into 24.0.

Comment 2 Dan Callaghan 2017-01-06 06:03:18 UTC
This will need to be fixed for 24.0 since it will break guest recipe execution.

Comment 3 Dan Callaghan 2017-01-06 06:46:34 UTC
https://gerrit.beaker-project.org/5568

Comment 6 Dan Callaghan 2017-02-21 18:50:01 UTC
Beaker 24.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.