Bug 1410790 - custom repos are not synced due to metalink.xml does not exist
Summary: custom repos are not synced due to metalink.xml does not exist
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 1340444
TreeView+ depends on / blocked
 
Reported: 2017-01-06 13:50 UTC by Pavel Studeník
Modified: 2017-03-14 13:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-14 13:30:11 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Studeník 2017-01-06 13:50:25 UTC
Description of problem:
I wanted create Fedora channel with synced packages from fedora's repository

https://mirrors.fedoraproject.org/metalink?repo=fedora-25&arch=x86_64

I received error and no packages were synced

ERROR: File /var/cache/rhn/reposync/1/External Fedora 25/metalink.xml does not exist

I tried same task on Satellite 5.7 and older version works good
spacewalk-backend-tools-2.3.3-45.el6sat.noarch

It looks that it is regression. 

Version-Release number of selected component (if applicable):
spacewalk-backend-tools-2.5.3-48.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create channel and add custom repository (https://mirrors.fedoraproject.org/metalink?repo=fedora-25&arch=x86_64)
2. try to sync repo by webui and look at log with result

Actual results:
= Satellite 5.8 =
2017/01/06 15:16:06 +03:00 Command: ['/usr/bin/spacewalk-repo-sync', '--channel', 'fedora25-x86_64', '--type', 'yum', '--latest', '--sync-kickstart']
2017/01/06 15:16:06 +03:00 Sync of channel started.
2017/01/06 15:16:06 +03:00 Repo URL: https://mirrors.fedoraproject.org/metalink?repo=fedora-25&arch=x86_64
2017/01/06 15:16:11 +03:00 ERROR: File /var/cache/rhn/reposync/1/External Fedora 25/metalink.xml does not exist
2017/01/06 15:16:11 +03:00 ERROR: File /var/cache/rhn/reposync/1/External Fedora 25/metalink.xml does not exist
2017/01/06 15:16:11 +03:00 Sync of channel completed in 0:00:05.


Expected results:
= Satellite 5.7 =
['/usr/bin/spacewalk-repo-sync', '--channel', 'fedora-25-x86_64', '--type', 'yum', '']
Repo URL: https://mirrors.fedoraproject.org/metalink?repo=fedora-25&arch=x86_64
Packages in repo:             51669
Packages passed filter rules:     3
Packages already synced:          0
Packages to sync:                 3
1/3 : kernel-modules-4.8.6-300.fc25-0.x86_64
2/3 : kernel-core-4.8.6-300.fc25-0.x86_64
3/3 : kernel-4.8.6-300.fc25-0.x86_64
Linking packages to channel.
Repo https://mirrors.fedoraproject.org/metalink?repo=fedora-25&arch=x86_64 has comps file df2eae999a4f7c464b743a16f112f1b3c039dc945c305578195524f83fb66833-comps-Everything.x86_64.xml.gz.
Repo https://mirrors.fedoraproject.org/metalink?repo=fedora-25&arch=x86_64 has 0 errata.
Sync completed.
Total time: 0:00:21

Comment 1 Gennadii Altukhov 2017-01-09 15:46:32 UTC
Pavel, I cannot reproduce with these steps. can you provide additional information for the reproducer?


Note You need to log in before you can comment on or make changes to this bug.