Bug 141084 - anaconda installer spews "rpmdb: PANIC: fatal region error detected; run recovery"
anaconda installer spews "rpmdb: PANIC: fatal region error detected; run reco...
Status: CLOSED DUPLICATE of bug 139146
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-28 23:59 EST by Bob Rintel
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 22:21:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gzipped anacdump.txt (137.00 KB, application/x-gzip)
2004-11-29 00:06 EST, Bob Rintel
no flags Details
install.log (338.34 KB, text/plain)
2004-11-29 00:07 EST, Bob Rintel
no flags Details
install.log.syslog (558 bytes, text/plain)
2004-11-29 00:08 EST, Bob Rintel
no flags Details
tarball with anaconda.log install.log syslog install.log.syslog anaconda-ks.cfg (41.26 KB, application/x-gzip)
2004-12-20 11:26 EST, Alexander Boström
no flags Details

  None (edit)
Description Bob Rintel 2004-11-28 23:59:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
Bug #112898 reported this problem in Fedora 1 and claims it's fixed in
later versions, but here is the same problem in Fedora 3.

I downloaded the DVD ISO, I ran the installer including the disk
check, and after the first 80 packages it started spewing "rpmdb:
PANIC: fatal region error detected; run recovery" for every package.

Following the advice in Bug #112898, I also tried "linux allowcddma"
and the result was the same.

Incidentally, I had the same problem in Fedora 2 also, but there I was
able to get around it by selecing no packages and using rpm to install
them all after booting.  But the minimum install always includes some
packages, and these caused the problem again in Fedora 3.

Version-Release number of selected component (if applicable):
fedora core 3

How reproducible:
Always

Steps to Reproduce:
1. run installation disk
2.
3.
    

Additional info:
Comment 1 Bob Rintel 2004-11-29 00:06:14 EST
Created attachment 107523 [details]
gzipped anacdump.txt
Comment 2 Bob Rintel 2004-11-29 00:07:42 EST
Created attachment 107524 [details]
install.log
Comment 3 Bob Rintel 2004-11-29 00:08:23 EST
Created attachment 107525 [details]
install.log.syslog
Comment 4 Barry K. Nathan 2004-11-29 02:25:26 EST
For FC3, does the install.log always show the problems happening after
openssl-0.9.7a-40.i686, or does the first problematic package change
each time?

It might help to know what kind of hardware you have.
Comment 5 Bob Rintel 2004-11-29 17:30:52 EST
Whatever packages I select from the list, or even if I select no
packages at all, the first 80 installed packages are the same, and the
80th one is the openssl package where the error occurs.

My hardware is an IBM Netvista A60.  The manuals don't give any
information about the internal components, but at bootup it says it
has a 1.7GHz Intel Pentium 4, Phoenix Bios 4.0 Release 6.0 version
P9KT23AUS, 256MB of 400MHz Rambus RAM, and a 256KB cache.  I also
replaced the hard disk with a Seagate ST360020A 60GB 5400RPM UltraATA,
and the CD-ROM drive with a Sony DRU-540A.  The monitor is a Sony
CPD-G400.

My current attempts involve trying to minimize the number of intiial
packages to get something installed so I can run rpm separately on the
additional packages.  I'm doing this by using a network install and
linking unnecessary packages to the vim-minimal package.  I still
haven't succeeded in getting a minimal set that installs without
errors and that boots successfully afterwards.  But in my latest
attempt the rpmdb error occurs after the up2date package, and if I
remove that one it will occur somewhere else again, so the problem is
in rpm and not in the packages.

Does anaconda even use rpm, or does it use its own internal version? 
Is there a way to get it to rebuild the database itself whenever the
error occurs and try again instead of just panicking?  I have the list
of packages I want, from another computer where Fedora 3 installs
successfully, so I'm trying to find a way to install them manually
onto the IBM machine.
Comment 6 Bob Rintel 2004-11-29 17:36:14 EST
Oh, it also has an Adaptec AHA-2940 SCSI card.
Comment 7 Barry K. Nathan 2004-11-30 04:24:55 EST
> Is there a way to get it to rebuild the database itself whenever the
> error occurs and try again instead of just panicking?

Whenever I've seen an RPM database get this corrupted this quickly
(albeit on an already-installed system, not from within anaconda),
rebuilding the database has always left me with a database missing at
least half of the packages, probably more. (But each of those cases
has been bad hardware, too, and not quite as reproducible as your case.)

Has any Red Hat Linux, Red Hat Enterprise Linux, or Fedora Core
distribution ever installed onto this particular computer without
hitting this error?

If you have a Windows XP install CD around, does *that* manage to
install or does it explode (e.g. die with a bluescreen early on, etc.)?

Anyway, if you want to get your system up-and-running quickly, you
could try using a Knoppix CD on the problematic computer to do
something like this:
1. Partition the drive
2. Use tar & ssh (or dump & ssh) to copy the working computer's files
over to the problematic computer
3. Edit /etc/grub.conf and /etc/fstab as appropriate [also, change
those paths to account for the fact that you're booted off the Knoppix
CD -- or chroot to the copied FC3 installation and edit from there]
4. chroot into the FC3 installation if you haven't already, and run
grub-install there
5. Boot into the installed system and let kudzu reconfigure things as
needed

but that's just a quick hack and doesn't get to the root of the problem...

One last suggestion, if you have the time: Does installing FC2 then
upgrading to FC3 *using yum instead of anaconda* work? For instance,
try these instructions:
http://www.linux.duke.edu/~skvidal/misc/fc2-fc3-update-with-yum.txt
Comment 8 Bob Rintel 2004-11-30 12:25:37 EST
Red Hat Linux 6.1, 7.1, and 7.2 installed and ran fully (for 3.5
years) without even once having an rpmdb error (or any other kind of
Linux system error).

Fedora 2 installs the minimum if you select no optional packages, and
then rpm works fine at installing the remaining packages after
booting. But Fedora 1 and Fedora 3 don't.

I've also been running Windows NT on that machine for 3.5 years
without any problems unique to that machine.

Thanks for the yum suggestion: I'll try it.
Comment 9 Alexander Boström 2004-12-20 11:25:20 EST
I just saw this on RHEL4 beta 2 (nahant).

Will attach the logs I could find and see if it's reproducible.
Comment 10 Alexander Boström 2004-12-20 11:26:50 EST
Created attachment 108904 [details]
tarball with anaconda.log install.log syslog install.log.syslog anaconda-ks.cfg
Comment 13 Chris C. 2005-01-07 17:17:02 EST
Everything above sounds like my problem. The same problem is discused 
in bug #139146 and is not resolved yet.
Comment 20 Jeremy Katz 2005-02-01 22:21:05 EST

*** This bug has been marked as a duplicate of 139146 ***

Note You need to log in before you can comment on or make changes to this bug.