This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 141091 - [PATCH] disk ordering fails raidstart
[PATCH] disk ordering fails raidstart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: raidtools (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-11-29 02:40 EST by Wendy Cheng
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 13:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
raidstart patch to fix this issue. (499 bytes, text/plain)
2004-11-29 02:48 EST, Wendy Cheng
no flags Details

  None (edit)
Description Wendy Cheng 2004-11-29 02:40:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:

Reported via IT#53591
Customer: IBM-IGS/HSBC Bank Brazil

If you have a mirrored raid device ( raid level 1 ), and one disk
encounters fatal errors, the raid device continues to operate on the
other disk, as expected.

However if the device is stopped and restarted then the raidstart will
fail if the failing hardware is the first listed in the raidtab ( e.g.
raid-disk 0 ).

If the first raid-disk is operational, then the md device will start
irrespective of the status of the second raid-disk.

The customer encountered the problem on an EMC array; it is also
recreated using my test machine on both AS2.1 and RHEL 3. 

The problem seems to be with raidstart, which only attempts the first
listed disk irrespective of the raid level. 



Version-Release number of selected component (if applicable):
raidtools-1.00.3-7

How reproducible:
Always

Steps to Reproduce:
1. Create an md device using 2-disk mirroring (say sdb1, sda1). Make
sure sdb1 is raid-disk 0.
2. Start the md device as usual - proves everything works.
3. Shutdown the system and remove sdb1.
4. Reboot and run raidstart. It will fails.    

Actual Results:  The raidstart command will fail since it can't find sdb1.

Expected Results:  The md should be able to pick up sda1 and operational.

Additional info:
Comment 1 Wendy Cheng 2004-11-29 02:48:06 EST
Created attachment 107526 [details]
raidstart patch to fix this issue.

Patch submitted by dstownse@us.ibm.com and tested by me. Red Hat TAM is Mike   
Gahagan.
Comment 2 Wendy Cheng 2004-11-29 02:56:10 EST
AS2.1 bugzilla: 141095.
Comment 3 Wendy Cheng 2004-12-10 11:13:46 EST
Anyword on this issue ? 
Comment 8 Dennis Gregorovic 2005-05-19 13:27:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-180.html
Comment 9 Dennis Gregorovic 2005-05-19 17:39:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-180.html

Note You need to log in before you can comment on or make changes to this bug.