Bug 14110 - typo in /etc/rc.d/init.d/network - static-routes doesn't work
typo in /etc/rc.d/init.d/network - static-routes doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 17324 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-17 05:57 EDT by Mads Kiilerich
Modified: 2014-03-16 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 05:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2000-07-17 05:57:22 EDT
/etc/sysconfig/static-routes doesn't work.

The following solves it:
--- network.org Mon Jul 17 11:51:37 2000
+++ network     Mon Jul 17 11:51:50 2000
@@ -69,7 +69,7 @@
        # Add non interface-specific static-routes.
        if [ -f /etc/sysconfig/static-routes ]; then
           grep "^any" /etc/sysconfig/static-routes | while read ignore
type dest netmask mask gw gateway; do
-             [ "${gateway}" != "${gateway##[0-9}" ] && \
+             [ "${gateway}" != "${gateway##[0-9]}" ] && \
                /sbin/route add -$type $dest $netmask $mask $gw $gateway
           done
        fi    

BTW: the format of /etc/sysconfig/static-routes is not documented anywhere
where I find it obvious... A man-page for it would be a good thing.

Regards,
Mads
Comment 1 Bill Nottingham 2000-07-18 12:18:14 EDT
Already fixed in the latest initscripts.
Comment 2 Bill Nottingham 2000-09-07 10:36:18 EDT
*** Bug 17324 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.