Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1411088 - bad default value of $ha_node_ips in the puppet confg class
Summary: bad default value of $ha_node_ips in the puppet confg class
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-opendaylight
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Tim Rozet
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 10:22 UTC by Alon Dotan
Modified: 2017-07-20 20:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-20 20:57:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alon Dotan 2017-01-08 10:22:00 UTC
Description of problem:
the default value of this variable in the redhat director environment should be hiera("opendaylight_api_node_ips") since there is no way to pass this variable via the director configuration files

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nir Yechiel 2017-07-20 08:37:23 UTC
@Tim, can you please review this bug? Is it still valid and worth fixing?

Thanks,
Nir

Comment 2 Tim Rozet 2017-07-20 20:57:31 UTC
In newton, ODL HA is not supported.  That is why the value is not passed in puppet-tripleo to puppet-opendaylight.  We have added HA support to master branch and as you mentioned the variable is being set appropriately:
https://github.com/openstack/puppet-tripleo/blob/master/manifests/profile/base/neutron/opendaylight.pp#L35


Note You need to log in before you can comment on or make changes to this bug.