Bug 141114 - authconfig prints critical error messages if samba isn't installed
Summary: authconfig prints critical error messages if samba isn't installed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: authconfig   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-29 13:56 UTC by Chris Ricker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: authconfig-5.1.0-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 15:35:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2004-11-29 13:56:47 UTC
authconfig fails if samba isn't installed

authconfig: critical error writing /etc//samba/smb.conf: No such file
or directory
[root@spamstop ~]# rpm -q samba-common
package samba-common is not installed
[root@spamstop ~]# 


This is related to bug #137321 (ie, the correct solution isn't simply
to add samba-common to the Requires for authconfig :-)

Comment 1 Tomas Mraz 2004-12-02 16:28:44 UTC

*** This bug has been marked as a duplicate of 137321 ***

Comment 2 Tomas Mraz 2005-08-24 08:38:35 UTC
Authconfig shouldn't write to configuration files which values haven't been changed.

This will be fixed in the process of rewriting authconfig in Python.



Note You need to log in before you can comment on or make changes to this bug.