Bug 1411274 - texlive-biblatex format version
Summary: texlive-biblatex format version
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 10:23 UTC by Michael Strobel
Modified: 2017-01-17 09:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-17 09:34:43 UTC
Type: Bug


Attachments (Terms of Use)
test .bib file (110 bytes, text/plain)
2017-01-16 19:32 UTC, Tom "spot" Callaway
no flags Details
test .tex file (242 bytes, text/plain)
2017-01-16 19:33 UTC, Tom "spot" Callaway
no flags Details

Description Michael Strobel 2017-01-09 10:23:34 UTC
Description of problem:
By upgrading to Fedora 25 bibliography using biber and biblatex stopped working.

Version-Release number of selected component (if applicable):
Name        : texlive-biblatex
Arch        : noarch
Epoch       : 6
Version     : svn42092
Release     : 22.fc25.1

Name        : biber
Arch        : noarch
Epoch       : 0
Version     : 2.6
Release     : 1.fc25

How reproducible:
LaTex document using biber and biblatex
\usepackage[backend=biber,style=numeric,natbib=true,backref=true]{biblatex}


Steps to Reproduce:
1. pdflatex file.tex
2. pdflatex stops saying "Package biblatex Warning: File 'diss-main.bbl' is wrong format version - expected 2.8"

head bib.bbl
% $ biblatex auxiliary file $
% $ biblatex bbl format version 2.5 $
% Do not modify the above lines!

Thanks for looking into that!

Comment 1 Tom "spot" Callaway 2017-01-16 19:32:09 UTC
Created attachment 1241376 [details]
test .bib file

Comment 2 Tom "spot" Callaway 2017-01-16 19:33:27 UTC
Created attachment 1241378 [details]
test .tex file

I cannot reproduce your issue. I've attached some simple test files that I used to try.

If you can send me a copy of your .tex and .bib, I'll see if I can reproduce with them.

Comment 3 Michael Strobel 2017-01-17 09:34:43 UTC
I tried to compile a minimal example and in the process it turned out that my Makefile was the problem. Some (obsolete) commands there triggered the problem. It's working fine now. 

Thanks for the feedback (and sorry for the inconvenience).


Note You need to log in before you can comment on or make changes to this bug.